Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
2 registered (Ken.C, wschwartz), 53 Guests and 5 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13317 Members
11 Forums
22875 Topics
404239 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17768
pmbuko 16273
SirQuack 13333
CV 11194
MarkSJohnson 10878
Meanwhile On Facebook

Love this comment from Doug T! "The M22 bookshelf speakers sound so clean and a...

󾓶 Andrew has spoken! Big update on the AxiomPlay Wireless Platform on the Axiom...

A New Look For Our Amps and Pre-amps? Adding yet another level of customization...

Hurry - sale ends Sunday!

Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#151095 - 11/10/06 12:24 AM EP350 Hum
Screefer Offline
buff

Registered: 11/02/06
Posts: 51
I received my M22v2's and EP350 sub on Monday.After carefully connecting everything I have a very noticable hum from the sub. I went thru all connections. Cable hook up, speaker connections etc and still had the hum even with the receiver turned off. It would vary in loudness.
I took a 3 prong extension cable and snipped one of the ground wires off and plugged the sub in with that. No more hum!!. How do I solve this problem and still ground my sub properly?

Top
#151096 - 11/10/06 12:38 AM Re: EP350 Hum [Re: Screefer]
Haoleb Offline
connoisseur

Registered: 09/25/02
Posts: 1488
Loc: Maine
Find out where your getting your ground loop from. If you have a cable box in the system check that first. Disconnect the cable feed going into it, If the humm goes away you need to get a transformer type device. Axiom even sells one.
_________________________
Haoleb's Audio/DIY Website

Top
#151097 - 11/10/06 12:53 AM Re: EP350 Hum [Re: Screefer]
BrenR Offline
connoisseur

Registered: 12/10/03
Posts: 3602
Loc: Winnipeg MB Canada
Alan's done a write-up here.

Should help you out.

Bren R.

Top
#151098 - 11/10/06 12:58 AM Re: EP350 Hum [Re: BrenR]
Screefer Offline
buff

Registered: 11/02/06
Posts: 51
I've disconnected the cable from the receiver and Tv. It still hums.

Top
#151099 - 11/10/06 01:36 AM Re: EP350 Hum [Re: Screefer]
bridgman Offline
axiomite

Registered: 08/25/04
Posts: 5394
Loc: Bowmanville, Ontario, Canada
Go back to the most basic setup and start from there. Just the receiver, speakers and sub, with both receiver and sub plugged into the same AC outlet and nothing but a wire antenna or CD/DVD player hooked into the receiver, again on the same outlet. Should be no hum. Add stuff from there and see when the hum starts.

Top
#151100 - 11/10/06 11:43 AM Re: EP350 Hum [Re: Screefer]
ravi_singh Offline
connoisseur

Registered: 03/14/02
Posts: 1351
Loc: Montreal
If you just plug in the power, and only the power, does it still hum?

If so, it might be power supply related.

Top
#151101 - 11/10/06 01:03 PM Re: EP350 Hum [Re: ravi_singh]
Screefer Offline
buff

Registered: 11/02/06
Posts: 51
Thanks for all the help. After connecting only the receiver and DVD player the hum went away. As soon as I connect the Tv inputs it hums. I have ordered a ground loop isolator from Axiom.
I must say the help from all of you is fantastic and I love my Axioms.

Top
#151102 - 11/10/06 11:01 PM Re: EP350 Hum [Re: Screefer]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10386
Kim, welcome. Glad to hear that you're enjoying your Axioms. One point about the sub hum is puzzling: you said that you disconnected the cable TV line(the most common cause of hum in AV setups)but the hum was still there. Then you said that connecting the "TV inputs" caused the hum to start. If you mean that the TV connection itself(without the cable feed)started the hum, then this isn't what the Axiom isolator is designed to correct; it's specifically for a loop running through the cable connection.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
#151103 - 11/13/06 02:03 PM Re: EP350 Hum [Re: JohnK]
Screefer Offline
buff

Registered: 11/02/06
Posts: 51
After disconnecting the cable from TV and receiver the hum is gone. I also contacted my local Cable provider and they would not even look at it. Maybe its time for a dish.

Top
#151104 - 11/13/06 07:45 PM Re: EP350 Hum [Re: Screefer]
bridgman Offline
axiomite

Registered: 08/25/04
Posts: 5394
Loc: Bowmanville, Ontario, Canada
I'm going from memory here, but I think I remember a couple of knowledgeable people identifying exactly what was wrong with the cable installation if you were getting hum, and possibly even the magic words you could use to get the cable guy to go "oh, I guess I could do that... long as I don't have to think..."

Top
#151105 - 11/16/06 08:59 PM Re: EP350 Hum [Re: bridgman]
Screefer Offline
buff

Registered: 11/02/06
Posts: 51
Yehaa, The hum is gone with the help of the isolator from Axiom. I think they will be seeing orders for a couple more from friends of mine in the area that have been having the same problem for awhile now. Same cable company that claims its not up to them. That makes me Hummm!!

Top
Page 1 of 2 1 2 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.