Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Positioning Floorstanding Speakers

Wall'O'Fame
Greetings fellow Axiom owners...
HG Rosewoods Part 3
Who's Online
0 registered (), 134 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13295 Members
11 Forums
22826 Topics
403268 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17741
pmbuko 16259
SirQuack 13318
CV 11146
MarkSJohnson 10832
Meanwhile On Facebook

A very fond farewell party last night . . . we miss you Noreen!

Hope everyone's got their summer favourite playlists cued up for the weekend! W...

(y) Love this customer review of the M2s! "the first time listening to my new a...

These LFR1100 speakers in custom Eggshell White are on their way to Taiwan (yes,...

Topic Options
Rate This Topic
#385074 - 11/04/12 09:30 AM Left speaker issues
Theschneid Offline
newbie

Registered: 11/04/12
Posts: 1
So I seem to have damaged my left speaker... It's an m60 v2 I believe. The tweeter and top mid cone are putting out no sound. Anyone have any idea if that could be a driver? Or did I actually blow 2 cones at the same time? My preamp has been having some issues itself but ive tested other input sources and skipped the preamp so i know thats not the problem. Also does anyone know if axiom sells parts? Or do I have to ship them the entire speaker? If I have to ship them the whole thing it seems like it might be just as affordable to just buy 1 speaker for $560.

Top
#385075 - 11/04/12 09:44 AM Re: Left speaker issues [Re: Theschneid]
SBrown Offline
aficionado

Registered: 11/16/10
Posts: 812
Loc: Victoria,BC
Get ahold of Axiom, they will take care of you, and yes they will ship you just the drivers.
_________________________
Beauty is in the eye of the beer holder.

Top
#385077 - 11/04/12 09:51 AM Re: Left speaker issues [Re: Theschneid]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 10832
Loc: Central NH
Swap your left and right speakers to verify that it is indeed the speaker and not something in the electronics.

But yeah, call Axiom if you do verify it's the speaker.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#385078 - 11/04/12 10:00 AM Re: Left speaker issues [Re: Theschneid]
alan Offline
connoisseur

Registered: 01/29/02
Posts: 3186
Loc: Toronto/New York/Dwight
Hi,

Follow Mark's advice on switching the speaker channels to make sure it's not your electronics that are at fault. The drivers are easy to change out if indeed you've damaged the drivers. You mentioned your preamp, but what amplifier are you using to drive the M60s, and what is the rated power output per channel into 8 ohms? Is it solid-state?

Regards,
Alan
_________________________
Alan Lofft,
Axiom Resident Expert

Top
#385087 - 11/04/12 01:26 PM Re: Left speaker issues [Re: Theschneid]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13318
Loc: Iowa
are the binding straps secure between the speaker terminals on the M60's?
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#385090 - 11/04/12 02:33 PM Re: Left speaker issues [Re: Theschneid]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 10832
Loc: Central NH
Ohhhhh... good question!
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#385095 - 11/04/12 08:07 PM Re: Left speaker issues [Re: Theschneid]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 17741
Loc: NoVA
Yeah, the binding straps are the first thing to leap to mind in this situation.
_________________________
I didn't do it, no one saw me, you can't prove anything.

Top
#385098 - 11/04/12 09:50 PM Re: Left speaker issues [Re: Theschneid]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10363
Dave, welcome. As both Randy and Ken point out, the strip connecting the top and bottom terminals may have come loose(e.g., through vibration)and left the top section(mid-range and tweeter)unconnected to the receiver if the speaker wire is attached to the bottom terminal. Although it's possible for two drivers to fail simultaneously, it's unusual.

Check for a tight connection and also try connecting the speaker wire to the top terminal if it's now on the bottom.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
#385099 - 11/04/12 10:08 PM Re: Left speaker issues [Re: Theschneid]
jakewash Offline
shareholder in the making

Registered: 12/26/03
Posts: 10398
Loc: Calgary, Alberta
I would also suggest swapping the drivers from the good speaker into the dead one, this will verify if the drivers themselves are gone vs. the crossover.
_________________________
Jason
-----------------
TTTHHHPPPPPTTTT!

My HT

Top
#385123 - 11/05/12 06:52 PM Re: Left speaker issues [Re: Theschneid]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13318
Loc: Iowa
Dave has vanished. smile
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.