Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Sneak Peek into Axiom’s Current Research and Development

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
0 registered (), 64 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13322 Members
11 Forums
22895 Topics
404600 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17781
pmbuko 16279
SirQuack 13337
CV 11208
MarkSJohnson 10899
Meanwhile On Facebook

󾓶 The first review of the LFR880s is out! "If you are adding or upgrading stere...

So much going on in this month's newsletter - new product announcements, a new v...

Love this comment from Doug T! "The M22 bookshelf speakers sound so clean and a...

󾓶 Andrew has spoken! Big update on the AxiomPlay Wireless Platform on the Axiom...

Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#395576 - 07/28/13 11:02 AM EP600 V2 Help
spx38 Offline
newbie

Registered: 07/28/13
Posts: 2
Hi everyone,

I'm new to this forum and have been using axiom products for a while now and have been loving them.

However the EP600 V2 sub has been giving me some problems lately. With the receiver/tv turned off the sub will make a thump sound at irregular intervals. It works prefectly fine when the receiver is on and is being used but the only issue is that it makes a thumping noises once the receiver is turned off. It has only been doing this for the last month out of the last 5 or so years of owning the sub. What would be the issue?

Thanks

Top
#395577 - 07/28/13 11:13 AM Re: EP600 V2 Help [Re: spx38]
BlueJays1 Offline
connoisseur

Registered: 09/19/08
Posts: 4079
Loc: Porch,enjoying Bombay Sapphire
Give Axiom a call and talk with their customer service. Your amp in the subwoofer might need to be serviced. Sounds like a possible issue with a capacitor.
_________________________
I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne

Top
#395578 - 07/28/13 11:31 AM Re: EP600 V2 Help [Re: spx38]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1846
I would call Brent first thing on Monday. Replacing the amp in the EP-600 is pretty easy.

Top
#395580 - 07/28/13 11:56 AM Re: EP600 V2 Help [Re: spx38]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 10899
Loc: Central NH
Unplug it for a few minutes and then plug it back in. It might just need a bit of a re-set.

If that doesn't work, yeah....call Axiom.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#395581 - 07/28/13 12:06 PM Re: EP600 V2 Help [Re: spx38]
michael_d Offline
connoisseur

Registered: 07/23/04
Posts: 3904
Loc: Up yonder
A few of us went through this before. If I recall, it's a ground issue. I think I just moved the grounding screw on the amp plate or something like that. As others have mentioned, call Axiom.
_________________________


Top
#395587 - 07/28/13 04:07 PM Re: EP600 V2 Help [Re: spx38]
cohesion Offline
local

Registered: 03/27/12
Posts: 215
Loc: Maple, Ontario, Canada
When you call you might ask about the new line of subs currently in development. Can't hurt to know what's coming and what kind of upgrade credit you could get. Just sayin'...

Top
#395588 - 07/28/13 05:26 PM Re: EP600 V2 Help [Re: spx38]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13337
Loc: Iowa
My 600v2 used to thump/rumble occasionally for no reason out of the blue. The first time I heard it it sounded like thunder off in the distance. Just unpluged the main outlet cable for a few minutes and that fixes it for me. For me it is paranormal activity...

_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#395594 - 07/28/13 09:39 PM Re: EP600 V2 Help [Re: spx38]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10395
Welcome. As a couple of replies have already suggested, unplug the sub for a few minutes to reset it to see if this helps. If the evil spirits which were affecting Randy's sub have also targeted yours, having no power cord to use as an entry way may cause them to become lost and to go looking for an easier victim.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
#395600 - 07/29/13 06:56 AM Re: EP600 V2 Help [Re: spx38]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 10899
Loc: Central NH
Yeah, John, but sometimes those same spirits come out the port (luckily, with no chuffing due to the vortex design) and take residence in the closets of the children.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#395729 - 08/02/13 09:46 AM Re: EP600 V2 Help [Re: spx38]
spx38 Offline
newbie

Registered: 07/28/13
Posts: 2
Thanks for all the replies. Greatly appreciated. I did what you guys suggested and unplugged the sub for half an hour and then plugged it back in again. It hasn't made an unwanted thump yet!

Thanks again for the help. The house is a lot nicer now that it doesn't sound like bear is pounding on the wall every couple of minutes haha.

If the issue comes up again, I will call axiom.

Top
Page 1 of 2 1 2 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.