Denon 3910 problem

Posted by: Ken.C

Denon 3910 problem - 12/29/05 12:14 AM

No, I don't have one...

But a friend of mine does. I've upgraded to the Denon LINK 3 firmware on it twice, and I found out tonight that it had lost that upgrade again; eg in the DLINK menu, it only shows OFF and 2nd, where before it showed OFF, 2nd, and 3rd. Anyone else encountering this? Anyone know what I'm talking about?
Posted by: pmbuko

Re: Denon 3910 problem - 12/29/05 01:06 PM

I think bigwill might have something to say about it.
Posted by: Ken.C

Re: Denon 3910 problem - 12/29/05 01:09 PM

Probably similar to what my friend said about it...
Posted by: Ken.C

Re: Denon 3910 problem - 12/29/05 01:39 PM

A follow up on this--since no one seems to know about Denon LINK 3--he's also considering switching to analog cables. Will that work for DVD video, or does he need a digital connection as well?
Posted by: Ajax

Re: Denon 3910 problem - 12/29/05 01:51 PM

The 5.1 analog connection will work for DVD videos. BUT, his processor wouldn't be applying any bass management or other processing to the multichannel inputs. The 3910 would be doing the digital to analog conversion, and he's have to set up the speaker sizes and distances in the 3910, assuming that's possible. Is there some reason he can't just use a standard digital output, coax or optical, from his Denon to his processor?
Posted by: Ken.C

Re: Denon 3910 problem - 12/29/05 02:04 PM

I'm just trying to make it as straightforward as possible; which seemed to be the DenonLINK. Sadly, it seems that I was wrong about that.



Hmm... I just looked at the manual, and at first glance, firewire should work for all of the various formats. Can anyone confirm this? If so, what's the point of DenonLINK at all?