EP 350 Sub Making Roaring Sound

Posted by: KSTx

EP 350 Sub Making Roaring Sound - 07/15/13 10:07 PM

My sub has started making a roaring noise lately that makes it useless to have on. What is wrong and what can be done to fix it? Need help on this.
Posted by: KSTx

Re: EP 350 Sub Making Roaring Sound - 07/15/13 10:09 PM

By the way it is approximately 3 years old.
Posted by: SirQuack

Re: EP 350 Sub Making Roaring Sound - 07/15/13 10:33 PM

when you unplug the RCA coax line in, but leave the power connected does it still make the noise? Also, what if you unplug the AC for a few minutes and then plug it back in, do you still have the noise?
Posted by: KSTx

Re: EP 350 Sub Making Roaring Sound - 08/03/13 02:18 PM

I had the sub on and it was making the roaring sound, I unplugged the line in and yes it still made the sound.
Posted by: Ken.C

Re: EP 350 Sub Making Roaring Sound - 08/03/13 02:39 PM

Probably a bad cap. Call Axiom.
Posted by: KSTx

Re: EP 350 Sub Making Roaring Sound - 08/03/13 03:12 PM

I sent an email to them and have not heard back. I guess I'll have to phone like you said.
Thanks.
Posted by: JohnK

Re: EP 350 Sub Making Roaring Sound - 08/03/13 09:33 PM

Kim, you didn't say if you also unplugged the power cord for a few minutes. This might not be the type of sound that this would cure(a couple days ago a thumping noise in another thread was stopped by unplugging to reset the sub amp), but you should give it a try anyway if you haven't already done so.
Posted by: KSTx

Re: EP 350 Sub Making Roaring Sound - 10/27/13 02:50 PM

Axiom called and I boxed up the amp out of the unit and shipped it off. It is supposed to be on its way back now. Waiting to re-install it.