Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
2 registered (Ajax, Boltron), 69 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13315 Members
11 Forums
22873 Topics
404159 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17766
pmbuko 16273
SirQuack 13333
CV 11191
MarkSJohnson 10875
Meanwhile On Facebook

󾓶 Andrew has spoken! Big update on the AxiomPlay Wireless Platform on the Axiom...

A New Look For Our Amps and Pre-amps? Adding yet another level of customization...

Hurry - sale ends Sunday!

Get a Gift Card Worth 20% of Your Purchase! Save hundreds!

Page 2 of 9 < 1 2 3 4 5 6 7 8 9 >
Topic Options
Rate This Topic
#239949 - 01/13/09 12:43 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: Dominick]
JaimeG Offline
aficionado

Registered: 12/25/02
Posts: 556
Loc: Ashburn, VA
 Quote:
OK, what else do you suggest I try before I get the Emotiva?


Do you use some sort of equalization at the pre amp? If yes, try to bypass it and hear if you get the same distortion. I google your amp, it seems to be more than capable to run your M80s, unless you really want them loud .
_________________________
The sailor does not pray for wind, he learns to sail. --Lindborg

Top
#239952 - 01/13/09 12:55 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: JaimeG]
Dominick Offline
frequent flier

Registered: 01/13/09
Posts: 11
At sirquack: unfortunately I have been using this Luxman with much success over the years. No other receivers laying around.

At JaimeG:
I have been running all equalization on flat. Lowering db's in the lower end of the spectrum seems to eliminate the noise, but ruins the fullness of my sound. I am 100% sure the speakers shouldnt be distorting like this at 40 watt bass peaks.

Top
#239955 - 01/13/09 01:07 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: Dominick]
JaimeG Offline
aficionado

Registered: 12/25/02
Posts: 556
Loc: Ashburn, VA
Hmm, if the eq. is flat or even a little hot on the lower freq is fine. Do u have access to a decibel meter or sound level meter? I'd be curious to know at what dbl the 'fart-distortion' appears.
_________________________
The sailor does not pray for wind, he learns to sail. --Lindborg

Top
#239959 - 01/13/09 01:21 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: JaimeG]
Murph Offline
axiomite

Registered: 10/05/06
Posts: 6805
Loc: PEI, Canada
Perhaps they are from France and they are simply choosing to "Fart in your general direction?"

OK Monty Python isn't helping, is it?

Personally, i would borrow a friends receiver and maybe even his/her dvd player as a source. If it still occurs, you know your next call is to Axiom. If not, hook the new DVD player to your old amp and see if it occurs. If it does, you just justified your new Emotiva to whomever you might need to justify it to. Wife, your conscious, annoying 'Great Gazoo' like angel that sits on your shoulder and complains.....
_________________________
With great power comes Awesome irresponsibility.

Top
#239960 - 01/13/09 01:23 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: Dominick]
LT61 Offline
aficionado

Registered: 02/23/04
Posts: 836
Loc: Illinois.
 Quote:
OK, what else do you suggest I try before I get the Emotiva?


If all else fails, and you don't want to buy another AMP.....you could return the M80s, and order the M60s. They will do fine, and provided there is not another problem....no more egg frying Amp.
_________________________
LIFE: "Choices, balance, and timing"

(Larryism)

Top
#239966 - 01/13/09 01:42 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: LT61]
lhulls Offline
veteran

Registered: 10/13/06
Posts: 139
Loc: Niagara Region, Canada
Hello

Here’s something you might consider trying, provided you have a 1/8th stereo male mini jack to a stereo RCA pair male cable and a portable CD player or Mp3 player.
First and foremost – turn power amp OFF, OFF,OFF!!! Turn volume down to zero on whatever player your using. If the amp has a level control, turn that down also as a precaution.
Now connect to player to the amp’s inputs and turn player on, then turn amp on.
Find a piece of music to test system with and SLOWLY bring up volume on player. (and amp if applicable)

Good luck.

Remember to shut power off on amp before any connections or disconnection of cables.
_________________________
Those who have long enjoyed such privileges as we enjoy forget in time that men died to win them.

Top
#239979 - 01/13/09 02:23 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: Dominick]
alan Offline
connoisseur

Registered: 01/29/02
Posts: 3187
Loc: Toronto/New York/Dwight
Hello Dominick,

Congrats on getting the M80s. First, let me say that your Luxman is nearing or at the end of its useful life. That said, Luxman amps back in the old days were well designed and yours should drive a 4-ohm load without difficulty. Do you still have the specs on the Luxman? Does it have power output ratings (RMS) into 4-ohm loads? Older stereo amplifiers were quite robust and could drive 4-ohm loads easily.

The M80s should not be doing what you're hearing. I suspect it's sound card related or perhaps the Luxman has aged and its output section is having trouble with the 4-ohm load of the M80s.

By the way, despite Emotiva's claims, some of their amplifiers have also shut down driving M80s. Axiom M80 owners have documented the Emotiva problems on this forum.

The brands of AV receivers that have no trouble driving the M80s include Denon, Harman/Kardon, Sherwood Newcastle, Rotel, Outlaw Audio and NAD. Even entry-level models of these brands will handle the 4-ohm M80s.

Regards,
_________________________
Alan Lofft,
Axiom Resident Expert

Top
#239980 - 01/13/09 02:24 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: lhulls]
Dominick Offline
frequent flier

Registered: 01/13/09
Posts: 11
Thank you everyone for the responses. As of right now, I am going to wait for the Emotiva XPA-3 to arrive and test out prob by Friday of this week. If that doesnt work I am going to borrow a friends different pre-amp/processor and use a standard DVD player to test. I will keep everyone posted.

I dont think its the speakers because they both distort, either right or left. Personally, I would think that would be highly unlikely to have both speakers distort.

Dom

Top
#239985 - 01/13/09 02:36 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: alan]
Dominick Offline
frequent flier

Registered: 01/13/09
Posts: 11
Alan,
Thanks a bunch for the information. I have searched all over the internet on information on my OLD MAN amp, but the only thing I can find is RMS 8 ohm ratings of 140w X 2.. Other than that, I am unsure if this amp would have a problem driving a 4 ohm load.

The ideal scenario for me would be honestly that the Luxman amp is getting very old, running out of steam, and having trouble driving a 4 ohm load. I am keeping my fingers crossed that when the Emotiva comes in, all of my problems will magically go away. I plan on keeping the Luxman for driving surrounds.

Thanks again for your help!

Dom

Top
#240449 - 01/15/09 02:42 PM Re: M80 v2's Arrived. Happy but slight issue. [Re: Dominick]
Dominick Offline
frequent flier

Registered: 01/13/09
Posts: 11
Please excuse my excitement throughout the rest of this paragraph! lol

Well, the verdict is in! It was my Luxman Amp!!!!!!!!!!!! I hit the nail on the head with this one. It turns out the 3 to 4-ohm load of the M80 v2's was too much for the 20 year old amp to handle. I plugged in my Emotiva XPA-3 this morning and have been running the amp for the last 5 hours straight without a hiccup!!!! These speakers are absolutely stunning! It is a night and day difference now with this new amp. The bass is extremely tight and powerful, you can definitely notice that there is NEVER a lack of power during any peaks and you can basically go as loud as humanly possible on the volume. No distortion, no problems with sound whatsoever, just clean increases in volume! sick!!!! Let me go back to my music. Talk to you guys later and thanks a bunch for the help!

Dominick

Top
Page 2 of 9 < 1 2 3 4 5 6 7 8 9 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.