Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Sneak Peek into Axiom’s Current Research and Development

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
3 registered (a401classic, Ken.C, medic8r), 59 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13322 Members
11 Forums
22895 Topics
404590 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17781
pmbuko 16277
SirQuack 13336
CV 11208
MarkSJohnson 10899
Meanwhile On Facebook

󾓶 The first review of the LFR880s is out! "If you are adding or upgrading stere...

So much going on in this month's newsletter - new product announcements, a new v...

Love this comment from Doug T! "The M22 bookshelf speakers sound so clean and a...

󾓶 Andrew has spoken! Big update on the AxiomPlay Wireless Platform on the Axiom...

Page 2 of 14 < 1 2 3 4 ... 13 14 >
Topic Options
Rate This Topic
#330705 - 12/08/10 07:11 AM Re: EP500 Not working [Re: MarkSJohnson]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Originally Posted By: MarkSJohnson
Dana, look at this situation very carefully.

You're having a conversation with Randy, and it's a known fact that his system has (had?) Poltergeists.

Now, you write:
"worked fine then. Damnest thing I've ever seen. Everytime I get a new toy, something breaks. Call it bad luck, I don't know. "

YOU may not know.

But _I_ do.

It's transference, my friend. I think I saw it on an episode of Buffy, so it must be true,

The PorterPlex Poltergeist has officially moved to YOUR system.

Be afraid.






Be very afraid.



Now that's funny! Thanks Mark I feel better actually, no wait...I forgot I'm still pissed! laugh
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#330717 - 12/08/10 09:53 AM Re: EP500 Not working [Re: Dduval]
ClubNeon Offline
connoisseur

Registered: 02/06/09
Posts: 3448
Loc: Western Maryland, USA
It's possible for devices with switch mode power supplies (which is just about everything these days) to cause huge voltage spikes between other devices when they are connected together. Enough to blow out an input or output circuit. When connecting receivers to amps the power should always be disconnected, not just in standby.
_________________________
Pioneer VSX-1018AH-K, PDP-5020FD, DV-79AVi
Axiom M22s, VP150, QS8s
Sony PS3, surround backs
-Chris

Top
#330730 - 12/08/10 12:17 PM Re: EP500 Not working [Re: ClubNeon]
jakewash Offline
shareholder in the making

Registered: 12/26/03
Posts: 10398
Loc: Calgary, Alberta
Yup I now turn everything OFF to ensure no odd power surges. A pain when swapping out speakers and you are trying to do it quickly.
_________________________
Jason
-----------------
TTTHHHPPPPPTTTT!

My HT

Top
#330735 - 12/08/10 12:42 PM Re: EP500 Not working [Re: jakewash]
ClubNeon Offline
connoisseur

Registered: 02/06/09
Posts: 3448
Loc: Western Maryland, USA
Ironically enough, it's probably safer to connect speakers while the receiver is in standby than the line-level interconnects.
_________________________
Pioneer VSX-1018AH-K, PDP-5020FD, DV-79AVi
Axiom M22s, VP150, QS8s
Sony PS3, surround backs
-Chris

Top
#330736 - 12/08/10 12:50 PM Re: EP500 Not working [Re: ClubNeon]
Ken.C Online   content
shareholder in the making

Registered: 05/03/03
Posts: 17781
Loc: NoVA
Oops.
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
#330738 - 12/08/10 01:09 PM Re: EP500 Not working [Re: Ken.C]
ClubNeon Offline
connoisseur

Registered: 02/06/09
Posts: 3448
Loc: Western Maryland, USA
Not saying that it'll happen every time, or with every piece of gear. But there can be potential between the grounds of equipment using switch-mode PS. If you connect the grounds (which in the case of RCA cables is also the signal path) at just the wrong time (depending on the phase of the power from the wall) there can be quite a bit of voltage differential between the two components. It will equalize quickly through the input/output circuit.

Another reason to like XLR connections: the chassis ground connects first before the sensitive signal connections are made.
_________________________
Pioneer VSX-1018AH-K, PDP-5020FD, DV-79AVi
Axiom M22s, VP150, QS8s
Sony PS3, surround backs
-Chris

Top
#330797 - 12/08/10 07:20 PM Re: EP500 Not working [Re: ClubNeon]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13336
Loc: Iowa
Dana I am sorry the force is weak in you and you have moved to the dark side. Mark is right, I have had my share of mysterious subwoofer issues in the past.


_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#330802 - 12/08/10 08:01 PM Re: EP500 Not working [Re: SirQuack]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Nah,

I'm not worried, I don't believe in that crap. There's no way...
Oh NO! My TV just went out! Damn! There goes my PS3! OH GOD! NOOOOO....not my Wife's big rubber ***K!

Curse you Mark! You too Randy! laugh shocked cry
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#330810 - 12/08/10 08:28 PM Re: EP500 Not working [Re: Dduval]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13336
Loc: Iowa
I'm just glad that Mark's curse has left Iowa, lol.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#330828 - 12/08/10 10:15 PM Re: EP500 Not working [Re: SirQuack]
Argon Offline
connoisseur

Registered: 07/24/04
Posts: 1443
Loc: Oak Ridge, NC
Originally Posted By: sirquack
Dana I am sorry the force is weak in you and you have moved to the dark side. Mark is right, I have had my share of mysterious subwoofer issues in the past.


Meeee Too!! It's Vu Ja DE!
_________________________
"A fanatic is someone who can't change his mind and won't change the subject" Churchill

Top
Page 2 of 14 < 1 2 3 4 ... 13 14 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.