Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Wall'O'Fame
Greetings fellow Axiom owners...
HG Rosewoods Part 3
Who's Online
0 registered (), 57 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13304 Members
11 Forums
22841 Topics
403608 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17751
pmbuko 16267
SirQuack 13321
CV 11160
MarkSJohnson 10848
Meanwhile On Facebook

Get a Gift Card Worth 20% of Your Purchase! Save hundreds!

Got your new In-Ceiling speakers yet? #atmosready http://axiomaudio.com/m3-in-c...

(y) Can't wait for the next evolution of surround sound to go mainstream!

Pre-order our new in-ceiling speakers and save 25%! Offer ends August 11th.

Page 12 of 14 < 1 2 ... 10 11 12 13 14 >
Topic Options
Rate This Topic
#333624 - 01/06/11 10:22 AM Re: EP500 Not working [Re: BlueJays1]
ClubNeon Offline
connoisseur

Registered: 02/06/09
Posts: 3448
Loc: Western Maryland, USA
I wonder if the newest amp chassis is physically compatible with the older EP600 cabinet.
_________________________
Pioneer VSX-1018AH-K, PDP-5020FD, DV-79AVi
Axiom M22s, VP150, QS8s
Sony PS3, surround backs
-Chris

Top
#333626 - 01/06/11 10:26 AM Re: EP500 Not working [Re: ClubNeon]
BlueJays1 Offline
connoisseur

Registered: 09/19/08
Posts: 4074
Loc: Porch,enjoying Bombay Sapphire
Originally Posted By: ClubNeon
I wonder if the newest amp chassis is physically compatible with the older EP600 cabinet.


If that is the case that would be a really dumb thing to change.
_________________________
I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne

Top
#333628 - 01/06/11 10:59 AM Re: EP500 Not working [Re: BlueJays1]
Robert_W Offline
old hand

Registered: 05/26/06
Posts: 88
Loc: NW Montana
House, thanks for posting that link. I'm absolutely convinced that they sent me a refurbished unit now. Some of the things Brent said to me make sense now. At first he thought they they needed to send me a 1/4 RCA adapter because there wasn't one on the new unit. I had no idea what he was talking about and told him there was and it didn't matter cause I was using XLR. He had sort of a quick "ah humina humina" moment and realized that I really didn't have a new amp I'm sure. Same thing with the colored wiring. He was telling about the new amp, assuring me that they had sent me a new one, then realized they hadn't and changed stride mid stream. Then quickly recovered and changed to "Oh....there's 2 different new versions". Yeah OK right.

So this brings forth all sorts of questions. If they did away with separate RCA connections and integrated them with the XLR doesn't this defeat the purpose of the XLR in the first place? Especially if an adapter is now used? How does one keep the signals separate? How does it work?

And even more importantly now that I've seen this I've lost a great deal of respect for these folks. I absolutely feel like I've been lied to and treated like hopefully I'd be just another dumb consumer that would accept a BS answer and just go away. They're trying to cover their asses / losses and send out older refurbed stuff under the guise of new. NOT cool at all. mad

These amp issues are obviously known to them. If they want to retain their so called great customer service then own up to it and send out a new amp in the first place. Especially when I paid for it and was told that was what I was getting!



Top
#333639 - 01/06/11 11:56 AM Re: EP500 Not working [Re: Robert_W]
ClubNeon Offline
connoisseur

Registered: 02/06/09
Posts: 3448
Loc: Western Maryland, USA
I didn't follow too closely, but I think there were some changes made at least in the EP500 that the newest amps don't fit in the old cabinet.

As for the RCA in XLR. The center connect is electrically separate from the balanced XLR pins. The change was made because one of the most common repairs was for people who broke their RCA jacks off because of how the cable went straight into the amp. Now with the right-angle adapter, the coax cable will point down, and there's nothing to snap off the amp.
_________________________
Pioneer VSX-1018AH-K, PDP-5020FD, DV-79AVi
Axiom M22s, VP150, QS8s
Sony PS3, surround backs
-Chris

Top
#333641 - 01/06/11 12:02 PM Re: EP500 Not working [Re: ClubNeon]
Happy Birthday terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4848
Loc: Tulsa, Oklahoma
Relax. Shit happens, they will get you a working amp.
_________________________
-David

Top
#333650 - 01/06/11 12:50 PM Re: EP500 Not working [Re: terzaghi]
Robert_W Offline
old hand

Registered: 05/26/06
Posts: 88
Loc: NW Montana
Originally Posted By: terzaghi
Relax. Shit happens, they will get you a working amp.


Yup, I'm pretty sure they will. However it still doesn't retract from the frustration level of having been through this now 4 times!

As I said, they are very nice to deal with on the phone. And they always seem willing to help. I do appreciate that. But I believe this could all have been solved the 3rd time by sending me a new amp. Now we're onto # 4 and more waiting for shipping / turn around etc etc. I think it's rather normal to be just a bit frustrated by now.

I just spoke with Brent again. Seems to be a good guy. Hopefully I'll get this resolved soon.

Top
#333652 - 01/06/11 01:01 PM Re: EP500 Not working [Re: Robert_W]
Happy Birthday terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4848
Loc: Tulsa, Oklahoma
Hope your issue is resolved soon. I know it is frustrating....
_________________________
-David

Top
#333653 - 01/06/11 01:02 PM Re: EP500 Not working [Re: Robert_W]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 17751
Loc: NoVA
As someone who does customer service (to some degree or other), I do not envy Brent. While I don't know the specifics of this situation at all, from personal experience I know the frustration of promising something to a customer/client/user, and not being in the direct loop to deliver it to them. Then one's wonderful coworkers drop the ball. Like I said, I have no indication whether this happened here or not.
_________________________
I didn't do it, no one saw me, you can't prove anything.

Top
#333654 - 01/06/11 01:03 PM Re: EP500 Not working [Re: Robert_W]
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6720
Loc: The Peoples Republic of Il.

I'd be frustrated also, seems natural to me.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#333657 - 01/06/11 01:25 PM Re: EP500 Not working [Re: Robert_W]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 10848
Loc: Central NH
For me, the biggest issue is that if you're paying for an amp, you should expect it to be a new one.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
Page 12 of 14 < 1 2 ... 10 11 12 13 14 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.