Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Positioning Floorstanding Speakers

Our Newest Flagship Model: The M100

Why We Make Our Own Drivers

Wall'O'Fame
"Serenity Cinema", now with 40% extra Serenity!
Updated as requested.
Who's Online
2 registered (Ajax, Da_Gimp_Pimp), 109 Guests and 12 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
12711 Members
11 Forums
22685 Topics
400514 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17696
pmbuko 16225
SirQuack 13311
CV 11062
MarkSJohnson 10680
Meanwhile On Facebook

8| Don't miss Andrew Welker's post on our message boards about the new subwoofer...

󾓲 The April Newsletter is out! Did you get your copy? http://www.axiomaudio.co...

Double-take! :O How well do you know our line? First one to spot the surprise...

Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#339198 - 02/19/11 02:56 PM EP600 Hum
Babyface Offline
frequent flier

Registered: 12/17/05
Posts: 17
Loc: Virginia Beach
I've had my EP600 for a long time. Started buzzing recently. I doubt it's ground loop. Disconnected from the LFE input and plugged with a cheater plug and it's still humming. Removing the ground screw makes it much worse. any advice

The sub is out of warranty by about 2 months, if the amp needs replacing, any clue what they cost?

Top
#339207 - 02/19/11 04:49 PM Re: EP600 Hum [Re: Babyface]
BlueJays1 Offline
connoisseur

Registered: 09/19/08
Posts: 4060
Loc: Porch,enjoying Bombay Sapphire
If you haven't made any changes to your system such as adding any new electronic components or cables and cheated the ground on the sub I highly doubt it is ground loop issue that is causing the humming. Does the sub still hum when there is no connection to the receiver, just plugged into the wall outlet?

It could very well be that the amp has kicked the bucket. Call support.
_________________________
I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne

Top
#339212 - 02/19/11 05:16 PM Re: EP600 Hum [Re: BlueJays1]
jakewash Offline
shareholder in the making

Registered: 12/26/03
Posts: 10394
Loc: Calgary, Alberta
If the sub still hums with only the eletrical power feed plugged into the wall then it is the amp and a call to Axiom should be done ASAP. I would hope they still cover it if it is just 2 months out of warranty or at least are very generous with costs.
_________________________
Jason
-----------------
TTTHHHPPPPPTTTT!

My HT

Top
#339213 - 02/19/11 05:27 PM Re: EP600 Hum [Re: jakewash]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13311
Loc: Iowa
I agree, I hate it when electronics go kapooey 1-2 months after warranty. I swear manufacturers do this on purpose. smile I would call Axiom right away, they man the ones late.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#339214 - 02/19/11 05:47 PM Re: EP600 Hum [Re: SirQuack]
Babyface Offline
frequent flier

Registered: 12/17/05
Posts: 17
Loc: Virginia Beach
It's a light, persistent hum. It's there even if the sub is just plugged into the wall. I think I was wrong on the warranty. Apparently the amp is only 3 years? I bought it Christmas '05.

The sub seems to works fine other than the hum. It's just noticeable and kind of bothersome. I can't unhear it. Cheater plug does nothing. Turning it off and unplugging it are the only solutions. I honestly think it started after my circuit breaker clipped one time recently. It's faint enough that maybe I missed until recently, but like I said, I can't unhear it.

I've contacted support. Hopefully I can find a resolution.

Top
#339216 - 02/19/11 05:49 PM Re: EP600 Hum [Re: Babyface]
CV Offline
Founder, Axiom Upgrade Club
shareholder in the making

Registered: 07/20/06
Posts: 11062
Loc: Richland, WA, USA
Yeah, I hope they have a nice resolution for you. That hum would bother me a lot.
_________________________
SuperGrand UltraDeluxe (Plus Extra More)

Top
#339224 - 02/19/11 06:21 PM Re: EP600 Hum [Re: Babyface]
Jc Offline
devotee

Registered: 06/27/06
Posts: 493
Loc: Sherbrooke, QC, Canada
Originally Posted By: Babyface
. . . I honestly think it started after my circuit breaker clipped one time recently . . .

Have you tried plugging it on a different circuit?
_________________________
jc
Axiom Audio Expert / jc@axiomaudio.com
Epic 80 - 180 - 800 (9.4 with dual centers) powered by dual A1400-8 = AUDIO NIRVANA

Top
#339226 - 02/19/11 06:36 PM Re: EP600 Hum [Re: Jc]
Babyface Offline
frequent flier

Registered: 12/17/05
Posts: 17
Loc: Virginia Beach
Originally Posted By: Jc

Have you tried plugging it on a different circuit?


Yes, it doesn't seem to matter.

Top
#339227 - 02/19/11 06:38 PM Re: EP600 Hum [Re: Babyface]
Babyface Offline
frequent flier

Registered: 12/17/05
Posts: 17
Loc: Virginia Beach
I don't mind paying to replace the amp(too much). Hopefully it would be an updated version, as mine is a v1. Although I don't know if later versions shared the shape amp shape.

For now I just turn it off when I'm not watching TV. Just knowing it's there erks me though. Should be silent.

Top
#339235 - 02/19/11 07:52 PM Re: EP600 Hum [Re: Babyface]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13311
Loc: Iowa
If it is under warranty I would assume you should not have to pay anything.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
Page 1 of 2 1 2 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.