Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Blind Listening Tests

Sneak Peek into Axiom’s Current Research and Development

Axiom’s Newest Speaker: The In-Ceiling M3

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
2 registered (Kevin1, MarkSJohnson), 59 Guests and 7 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13328 Members
11 Forums
22920 Topics
405201 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17789
pmbuko 16289
SirQuack 13340
CV 11236
MarkSJohnson 10941
Meanwhile On Facebook

Did you get your "Golden Email"? The great gift certificate email giveaway star...

Here's a helpful article for everyone looking at putting a new stereo or home th...

Interesting article about who's getting the money from streaming radio services...

Page 5 of 7 < 1 2 3 4 5 6 7 >
Topic Options
Rate This Topic
#349207 - 05/26/11 02:10 PM Re: EP500 will not power up [Re: stevej]
Murph Offline
axiomite

Registered: 10/05/06
Posts: 6863
Loc: PEI, Canada
Good Luck!
_________________________
With great power comes Awesome irresponsibility.

Top
#349303 - 05/27/11 10:34 PM Re: EP500 will not power up [Re: Murph]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Received the amp. It does not hook up with the 1/4 sub cable. It needs an xlr to 1/4 adapter that was suppose to be with the amp. Called and JC sent one right out. But I have the amp in and just waiting for the adapter. Tried to get one at the local radio shack but they didn't have one.
The new amp is much lighter than the old one. Not sure what that means.
So should be able to hook it up by the middle of next week.

Top
#349335 - 05/28/11 03:09 PM Re: EP500 will not power up [Re: stevej]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13340
Loc: Iowa
that sucks it didn't come with the adapter, hope they next day air you one so you can enjoy the amp. I wish they would have stayed with the regular RCA hookup, which is standard.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#349343 - 05/28/11 08:49 PM Re: EP500 will not power up [Re: SirQuack]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Yeah that is what I thought about the change in hookup. But I am sure that had a reason for it. The tracking showed it was on the FEDEX truck for delivery today, but it didn't make it. So I will have to wait until Tuesday now. Will let you know when I get it and try it out.

Top
#349348 - 05/29/11 12:58 AM Re: EP500 will not power up [Re: stevej]
obsi Offline
old hand

Registered: 11/14/09
Posts: 89
Loc: Philippines
Originally Posted By: stevej
Received the amp. It does not hook up with the 1/4 sub cable. It needs an xlr to 1/4 adapter that was suppose to be with the amp. Called and JC sent one right out. But I have the amp in and just waiting for the adapter. Tried to get one at the local radio shack but they didn't have one.
The new amp is much lighter than the old one. Not sure what that means.
So should be able to hook it up by the middle of next week.


Some of the reasons why I prefer the V2, no need for a phono adapter, trim control, heavy (vogue wink ) torroidal power supply, and it's amp plate somehow looks a lot more elegant. Hope yours gets sorted out, please keep us updated on your findings on the V2 vs V3 amp.


Edited by obsi (05/29/11 01:00 AM)
_________________________
Velo DD18,2xAxiom EP500,2xeD A7-450,2xSVS PB13U,2xSVS SB13P,2xInfinity Kappa12mbm, 2xB&W PCS8

Top
#349425 - 05/31/11 08:43 PM Re: EP500 will not power up [Re: obsi]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Received the adapter today and hooked it up. No sound at all from the sub. I have a call in to Axiom. Waiting for the return call. Will let you all know what the verdict is.

Top
#349427 - 05/31/11 09:27 PM Re: EP500 will not power up [Re: stevej]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13340
Loc: Iowa
frown
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#349428 - 05/31/11 09:37 PM Re: EP500 will not power up [Re: stevej]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10404
Ouch, Steve. One thing you might try, even though the previous problem didn't appear to have anything to do with the line level input, is to disconnect one of the main speaker wires and connect it to one set of the high level inputs.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
#349429 - 05/31/11 09:50 PM Re: EP500 will not power up [Re: JohnK]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Hi John. Just finished that. Brent recommended the same thing. Still nothing. Took the woofer out and made sure all connections are good. Left it out and tried again. The woofer doesn't move at all. Anyway, Brent is checking with the engineers in the morning and will get back with me. Will let you know what the outcome is. At least it is still under warranty and Axiom is willing to make sure it is taken care of.

Top
#349430 - 05/31/11 10:21 PM Re: EP500 will not power up [Re: stevej]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10404
Steve, if you mean that you also connected the speaker wire directly to the driver after you took it out, and got no movement, that would indicate that the voice coil is burned out.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
Page 5 of 7 < 1 2 3 4 5 6 7 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.