You are not logged in. [Log In]


Forums » General Discussion » Home Theater » HELP, My EP500 got damaged!

Page 1 of 6 1 2 3 4 5 6 >
Topic Options
Rate This Topic
#130876 - 03/07/06 11:48 AM HELP, My EP500 got damaged!
srthomas21 Offline
frequent flier

Registered: 03/07/06
Posts: 12
Hi

I bought a used EP500 sub and UPS damaged it in transit. It was well boxed in the manufacturers double box surrounded with styrofoam but UPS still magaged to break off the volume adjustment knob. It snapped clean off. I can't even get a hold of it with pliers to turn adjust the volume that way.

I talked to Axiom and they said the only way to fix it is to buy a brand new Amp to the tune of $600. Does anybody know of a better solution? I can't believe you just can't replace the volume adjustment knob.

I did insure it but UPS is probably going to fight me on it because the damage is so slight they aren't going to want to pay out $600 because a volume adjustment knob is broken.

Anyone have any experience taking the amp of the EP500 apart? Could the metal rod be welded back on or is it too small to do that?

Any help would be appreciated.

Scott

Top
#130877 - 03/07/06 12:05 PM Re: HELP, My EP500 got damaged!
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13565
Loc: Iowa
I am baffled on how just the Volume knob would have been sheered off, and none of the other controllers/knobs were damaged?

I would assume the knob was laying in the packaging? You might be able to use some sort of glue for metal, and glue the knob back on, not sure. Do you have any pictures so we can see what your up against?

This is to bad it happened to you, I'm sure you were trying to save a buck, not sure what you payed? Was it a lot less than the Factory Outlet price on a new one from Axiom?

You might be able to take off the amp plate, but you need special Star Torx screw drivers.
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
Anthem AVM60 Outlaw 7700 Emotiva A500 Epson 5040UB



Top
#130878 - 03/07/06 12:14 PM Re: HELP, My EP500 got damaged!
srthomas21 Offline
frequent flier

Registered: 03/07/06
Posts: 12
Hi

Thanks for your reply. No, nothing else was damged. I do have pics. I will upload them to my server and post the links.

I tried to find the factory outlet store and couldn't before I bought the used one. Can you point me to a link?

Scott

Top
#130879 - 03/07/06 12:21 PM Re: HELP, My EP500 got damaged!
srthomas21 Offline
frequent flier

Registered: 03/07/06
Posts: 12
Ok I found the link. I paid $775 for a less than one year old EP500. I also bought a pair of M60ti tower speakers for $575. Everything is in like new condition. I am happy with my purchase, just pissed at UPS. I should know by the end of the week if they will honor the claim. If not I hope I can fix the sub somehow. Thanks for all your help. Pictures coming soon of the damage.

Scott

Top
#130880 - 03/07/06 12:22 PM Re: HELP, My EP500 got damaged!
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
Factory outlet is on home page in print above the Architetcural series.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#130881 - 03/07/06 12:31 PM Re: HELP, My EP500 got damaged!
Gena Offline
veteran

Registered: 02/27/06
Posts: 120
I would be inclined to replace the potentiometer or to see if you can attach something to its shaft.

I don't know how good with your hands you are but the first thing you would need to do is to pull out the amp. You'd have to do it anyway if you decide to go the whole amp replacement route.

When you do it, find out what brand the potentiometer is, may be you can find the replacement on the web or Radio Shack. Also, when you take it out maybe there is enough of the shaft length left to attach something to it. Hard to say without seeing it, so just carefully remove the amp and go from there.

On the side note, it's hard to believe the knob got cleanly sheared off in the shipping. I would suspect a rough play from the previous owner. Can you contact him/her? I don't know what good would it do, though.

Good luck,

Gena


Top
#130882 - 03/07/06 12:42 PM Re: HELP, My EP500 got damaged!
sonicfox Offline
aficionado

Registered: 05/01/02
Posts: 914
Loc: Davenport, Iowa, USA
To put it quite frankly, that really sucks! I feel bad for you.

Anyway, you said it was "well boxed". Does it have visible damage on the box itself? Perhaps it got damaged while being packed and not during shipping. If that's the case, I would contact the previous owner with photos of the undamaged box as proof.
_________________________
M60s
VP150
QS8s
Marantz SR6003
Samsung LN52B550
Oppo DV-980H
Insignia NS-WBRDVD

Top
#130883 - 03/07/06 12:43 PM Re: HELP, My EP500 got damaged!
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6789
Loc: The Peoples Republic of Il.
I would look into getting a local electronics repair shop to do the work. It shouldn't cost to much for the repair, unfortunatly this is the risk of buying used.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#130884 - 03/07/06 12:46 PM Re: HELP, My EP500 got damaged!
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
I agree, if UPS did the damage the box would have been damaged as well, it would take a pretty precise direct hit to shear of the knob. I put a little suspect on the former owner.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#130885 - 03/07/06 12:49 PM Re: HELP, My EP500 got damaged!
spiffnme Offline
axiomite

Registered: 04/01/03
Posts: 5233
Loc: Los Angeles
If it was insured you'd better fight back and get yourself a new amp! I had some artwork delivered via UPS and they managaged to tear it. It was a small tear, but I fought back just as hard as they did, and they paid me. That's what you paid the insurance for!

DO NOT let them get away with this. File the insurance claim, and get it taken care of properly. Glue is not the answer!


_________________________
"A nation cannot prosper long, when it favors only the prosperous." -President Barack Obama

Top
Page 1 of 6 1 2 3 4 5 6 >

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,206 Registered Members
15 Forums
23,962 Topics
423,593 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13565
CV 11675
MarkSJohnson 11437
0 registered ()
224 Guests and
6 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup