You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » Vintage Sansui 8080DB

Topic Options
Rate This Topic
#176541 - 09/13/07 09:04 PM Vintage Sansui 8080DB
cgolf Offline
devotee

Registered: 03/14/05
Posts: 340
Loc: Cypress, Texas
This is for all you vintage lovers. I have a Sansui 8080DB that powers up, lights come on, comes out of protect mode but does nothing else. Meters don't register and there is no sound. When you push on the pins that join the preout and mains in the back it makes the dreaded "Humming". Any ideas??

Top
#176542 - 09/13/07 09:20 PM Re: Vintage Sansui 8080DB [Re: cgolf]
Mojo Offline
connoisseur

Registered: 01/21/07
Posts: 4613
My buddy has an old Sansui that consists of numerous daughter-cards plugged into a mother-board. Every year he takes it apart (which I understand is a big job) and cleans all the mating contacts. Perhaps that's what yours needs.

Top
#176543 - 09/13/07 09:42 PM Re: Vintage Sansui 8080DB [Re: cgolf]
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6789
Loc: The Peoples Republic of Il.

Try disconnecting the amp and pre amp sections and use a different amp and pre to trouble shoot which side the trouble is on.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,206 Registered Members
15 Forums
23,962 Topics
423,593 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13565
CV 11675
MarkSJohnson 11437
0 registered ()
219 Guests and
8 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup