You are not logged in. [Log In]


Forums » General Discussion » Home Theater » Popping sound from EP350 Sub-woofer

Topic Options
Rate This Topic
#180983 - 10/29/07 10:52 PM Popping sound from EP350 Sub-woofer
Hector Offline
newbie

Registered: 10/29/07
Posts: 2
I purchased an Epic Grand Master 350 System about 9 months ago. I've noticed a 'popping' sound emanating from the EP350 Sub-woofer sometimes. The sound is inconsistent, meaning that it may not happen for a couple of weeks then all of a sudden I'll hear the popping maybe once a minute for several minutes. I'd be interested to hear if anyone else has had this problem? Anyone know what the cause could be?

Top
#180987 - 10/29/07 11:09 PM Re: Popping sound from EP350 Sub-woofer [Re: Hector]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13565
Loc: Iowa
Does this only happen during certain types of activity like heavy explosions in movies, for example? Did you calibrate the sub with the speakers to the same SPL levels? How high are you running the volume on the sub (gain) knob, as well as in your receiver?

It is possible your running the sub to hot (volume gain to high) and during heavy action music/movies your getting port noise, not sure.
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
Anthem AVM60 Outlaw 7700 Emotiva A500 Epson 5040UB



Top
#180994 - 10/30/07 12:11 AM Re: Popping sound from EP350 Sub-woofer [Re: SirQuack]
Mojo Offline
connoisseur

Registered: 01/21/07
Posts: 4622
Hector, you need to call Axiom right away.

Top
#181009 - 10/30/07 06:59 AM Re: Popping sound from EP350 Sub-woofer [Re: Mojo]
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6789
Loc: The Peoples Republic of Il.


You are most likely running the sub to hot. Make sure it has been calibrated with the rest of the system.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#181024 - 10/30/07 09:47 AM Re: Popping sound from EP350 Sub-woofer [Re: Wid]
aouimet Offline
enthusiast

Registered: 06/15/07
Posts: 32
Loc: Michigan, USA
I had a problem with the 350 before. It wasnt popping, but it sounded like that at first to me. They did not have any air sealer behind all of the input jacks, so there was air coming out of the rca and other wire inputs. It was hard to notice, but came in at high volumes and sounded more like a bird chirping
_________________________
Adam O

M60s, VP150, QS4s, EP350, BD30, ONKYO605

Top
#181109 - 10/30/07 07:15 PM Re: Popping sound from EP350 Sub-woofer [Re: aouimet]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13565
Loc: Iowa
Good call as well, not a bad idea to check all the fasteners around the driver and amp to see if they are snug so no air gets by...

Oh Hector, oh Hector, where are you? \:\)

Did we scare you off?
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
Anthem AVM60 Outlaw 7700 Emotiva A500 Epson 5040UB



Top
#181145 - 10/30/07 11:04 PM Re: Popping sound from EP350 Sub-woofer [Re: Hector]
Hector Offline
newbie

Registered: 10/29/07
Posts: 2
Thanks guys for your responses!
I've had two different replies from Axiom on this. They both think it is an electrical problem. Told me to check co-axial cable and connections etc. They also suggested connecting A/C connection to a different wall outlet. I've done this now, but because this popping is so intermittent, I will have to leave it connected for several days to see if it cures the problem.

Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,208 Registered Members
15 Forums
23,964 Topics
423,627 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13565
CV 11675
MarkSJohnson 11437
1 registered (brendo)
195 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup