Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
Dead sub?
#325318 10/11/10 03:01 AM
Joined: Jun 2010
Posts: 4
D
newbie
OP Offline
newbie
D
Joined: Jun 2010
Posts: 4
Help, I think my sub might be dead.
Couple of days ago, I started hearing "knocking" thumping from my sub even when my amp was off. I turned off the sub thinking it was maybe some interference from somewhere.
Now, when I turned the sub back on, all I'm hearing is a hum from the it and nothing else even when music or a movie is playing.
The sub is a EP175, less then 1 year old.

Re: Dead sub?
DaveSmith #325319 10/11/10 03:19 AM
Joined: Apr 2007
Posts: 4,874
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,874
I'd definitely call axiom and see what they have to say. Sounds like an amp issue


-David
Re: Dead sub?
DaveSmith #325320 10/11/10 03:22 AM
Joined: Sep 2008
Posts: 4,116
connoisseur
Offline
connoisseur
Joined: Sep 2008
Posts: 4,116
Originally Posted By: DaveSmith
Help, I think my sub might be dead.
Couple of days ago, I started hearing "knocking" thumping from my sub even when my amp was off. I turned off the sub thinking it was maybe some interference from somewhere.
Now, when I turned the sub back on, all I'm hearing is a hum from the it and nothing else even when music or a movie is playing.
The sub is a EP175, less then 1 year old.


Definitely call Axiom. Those symptoms sound a lot like a defective amp on the sub or one about to fail. Leave the subwoofer turned off and unpluged in the meantime.


I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne
Re: Dead sub?
BlueJays1 #325321 10/11/10 03:30 AM
Joined: Apr 2007
Posts: 4,874
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,874
This reminds me of an issue I completely forgot I that had with my ep500 not long afer I bought it... I heard a thumping noise that I swear was someone in the attic but it turned out to be my sub. I unugged it and plugged it back in and it stopped. I think that it happened on another 1 or 2 occassions. I had no problems for the last couple of years until the recent issues described in my "ep500 stopped working" thread.





Last edited by terzaghi; 10/11/10 03:41 AM.

-David
Re: Dead sub?
terzaghi #325333 10/11/10 10:40 AM
Joined: Sep 2004
Posts: 11,451
shareholder in the making
Offline
shareholder in the making
Joined: Sep 2004
Posts: 11,451
Sub issues notwithstanding, those knocking sounds WERE COMING FROM THE ATTIC!!!

GET OUT....GET OUT WHILE YOU CAN!!!!


::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::
Re: Dead sub?
MarkSJohnson #325334 10/11/10 12:15 PM
Joined: Apr 2007
Posts: 4,874
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,874
Yeah, I was seriously about to call the police and my wife and I were really freaked out. I even poked my head into the attic and looked around with a flashlight!


-David
Re: Dead sub?
terzaghi #325335 10/11/10 12:51 PM
Joined: Sep 2004
Posts: 11,451
shareholder in the making
Offline
shareholder in the making
Joined: Sep 2004
Posts: 11,451
And you weren't even thinking about a scythe beheading you? smile


::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::
Re: Dead sub?
DaveSmith #325343 10/11/10 02:39 PM
Joined: Jun 2010
Posts: 4
D
newbie
OP Offline
newbie
D
Joined: Jun 2010
Posts: 4
Thanks everyone, I'm going to give them a call after Thanksgiving Monday. We should all get a day off wink

Re: Dead sub?
DaveSmith #325344 10/11/10 02:57 PM
Joined: Apr 2007
Posts: 4,874
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,874
Is today Canadian thanksgiving?


-David
Re: Dead sub?
terzaghi #325346 10/11/10 03:00 PM
Joined: Apr 2007
Posts: 4,874
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,874
Yeah the thumping thing was really creepy mark- My receiver and everything was turned off so I didn't suspect my sub at all. I was a little apprehensive about peaking in the attic but I thought maybe it was some type of animal up there... But it was so loud I thought maybe it was a person. Either way I had to look. Yikes!


-David
Page 1 of 2 1 2

Moderated by  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Link Copied to Clipboard

Need Help Graphic

Forum Statistics
Forums16
Topics24,434
Posts433,029
Members15,428
Most Online2,082
Jan 22nd, 2020
Top Posters
Ken.C 18,044
pmbuko 16,437
SirQuack 13,693
CV 11,828
MarkSJohnson 11,451
Who's Online Now
0 members (), 235 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Newsletter Signup
Powered by UBB.threads™ PHP Forum Software 7.7.4