You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » Dead sub?

Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#325318 - 10/10/10 11:01 PM Dead sub?
DaveSmith Offline
newbie

Registered: 06/27/10
Posts: 4
Help, I think my sub might be dead.
Couple of days ago, I started hearing "knocking" thumping from my sub even when my amp was off. I turned off the sub thinking it was maybe some interference from somewhere.
Now, when I turned the sub back on, all I'm hearing is a hum from the it and nothing else even when music or a movie is playing.
The sub is a EP175, less then 1 year old.

Top
#325319 - 10/10/10 11:19 PM Re: Dead sub? [Re: DaveSmith]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
I'd definitely call axiom and see what they have to say. Sounds like an amp issue
_________________________
-David

Top
#325320 - 10/10/10 11:22 PM Re: Dead sub? [Re: DaveSmith]
BlueJays1 Offline
connoisseur

Registered: 09/19/08
Posts: 4116
Loc: Porch,enjoying Bombay Sapphire
Originally Posted By: DaveSmith
Help, I think my sub might be dead.
Couple of days ago, I started hearing "knocking" thumping from my sub even when my amp was off. I turned off the sub thinking it was maybe some interference from somewhere.
Now, when I turned the sub back on, all I'm hearing is a hum from the it and nothing else even when music or a movie is playing.
The sub is a EP175, less then 1 year old.


Definitely call Axiom. Those symptoms sound a lot like a defective amp on the sub or one about to fail. Leave the subwoofer turned off and unpluged in the meantime.
_________________________
I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne

Top
#325321 - 10/10/10 11:30 PM Re: Dead sub? [Re: BlueJays1]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
This reminds me of an issue I completely forgot I that had with my ep500 not long afer I bought it... I heard a thumping noise that I swear was someone in the attic but it turned out to be my sub. I unugged it and plugged it back in and it stopped. I think that it happened on another 1 or 2 occassions. I had no problems for the last couple of years until the recent issues described in my "ep500 stopped working" thread.






Edited by terzaghi (10/10/10 11:41 PM)
_________________________
-David

Top
#325333 - 10/11/10 06:40 AM Re: Dead sub? [Re: terzaghi]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 11444
Loc: Central NH
Sub issues notwithstanding, those knocking sounds WERE COMING FROM THE ATTIC!!!

GET OUT....GET OUT WHILE YOU CAN!!!!
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#325334 - 10/11/10 08:15 AM Re: Dead sub? [Re: MarkSJohnson]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
Yeah, I was seriously about to call the police and my wife and I were really freaked out. I even poked my head into the attic and looked around with a flashlight!
_________________________
-David

Top
#325335 - 10/11/10 08:51 AM Re: Dead sub? [Re: terzaghi]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 11444
Loc: Central NH
And you weren't even thinking about a scythe beheading you? smile
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#325343 - 10/11/10 10:39 AM Re: Dead sub? [Re: DaveSmith]
DaveSmith Offline
newbie

Registered: 06/27/10
Posts: 4
Thanks everyone, I'm going to give them a call after Thanksgiving Monday. We should all get a day off wink

Top
#325344 - 10/11/10 10:57 AM Re: Dead sub? [Re: DaveSmith]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
Is today Canadian thanksgiving?
_________________________
-David

Top
#325346 - 10/11/10 11:00 AM Re: Dead sub? [Re: terzaghi]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
Yeah the thumping thing was really creepy mark- My receiver and everything was turned off so I didn't suspect my sub at all. I was a little apprehensive about peaking in the attic but I thought maybe it was some type of animal up there... But it was so loud I thought maybe it was a person. Either way I had to look. Yikes!
_________________________
-David

Top
Page 1 of 2 1 2 >

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,260 Registered Members
16 Forums
24,055 Topics
424,806 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13576
CV 11681
MarkSJohnson 11444
0 registered ()
169 Guests and
5 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup