You are not logged in. [Log In]


Forums » General Discussion » Advice from Axiom Owners » IMPORTANT INFORMATION EP600 SUBWOFFER

Page 3 of 3 < 1 2 3
Topic Options
Rate This Topic
#332786 - 12/29/10 06:29 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: Dduval]
da-drifter Offline
enthusiast

Registered: 12/08/10
Posts: 30
Thanks Dana!
_________________________
Samsung 65" 3D LCD TV, Samsung 3D Blu-Ray Disc Player, Denon AVR 3311CI, EP800, M80's, VP150, 4QS8's

Top
#332791 - 12/29/10 07:11 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: da-drifter]
jakewash Offline
shareholder in the making

Registered: 12/26/03
Posts: 10420
Loc: Calgary, Alberta
Just curious about the sub cable you are using. Did you try a different cable? I know I have one with poor shielding and if my kids are goofing around near the cable, I can get odd pops etc out of my sub.
_________________________
Jason
M80 v2
VP160 v3
QS8 v2
PB13 Ultra
Denon 3808
Samsung 85" Q70

Top
#332792 - 12/29/10 07:39 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: jakewash]
da-drifter Offline
enthusiast

Registered: 12/08/10
Posts: 30
No. I didn’t try a different cable. The cable is about 50 ft long and is run through my attic. I used the specified shielding and connectors recommended from Axiom and had it installed by their local installer. I did everything to exact specifications. But why does this matter? Axiom agreed that this is a fault in their software. This post is about informing people that the EP600 currently has some negative issues.
_________________________
Samsung 65" 3D LCD TV, Samsung 3D Blu-Ray Disc Player, Denon AVR 3311CI, EP800, M80's, VP150, 4QS8's

Top
#332793 - 12/29/10 09:49 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: da-drifter]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4872
Loc: Tulsa, Oklahoma
If I recall you said that even with the new amp without a software problem you said you have experienced some popping? I think Jason was just pointing out that sometimes little things (like cables) may be the culprit.
_________________________
-David

Top
#332808 - 12/30/10 05:43 AM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: terzaghi]
jakewash Offline
shareholder in the making

Registered: 12/26/03
Posts: 10420
Loc: Calgary, Alberta
David is correct .
_________________________
Jason
M80 v2
VP160 v3
QS8 v2
PB13 Ultra
Denon 3808
Samsung 85" Q70

Top
#332811 - 12/30/10 07:03 AM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: da-drifter]
RickF Offline
axiomite

Registered: 02/26/05
Posts: 5210
Loc: Vero Beach, Florida
Originally Posted By: da-drifter
This post is about informing people that the EP600 currently has some negative issues.

Yea but...

Originally Posted By: da-drifter
Now, after replacing everything in the speaker cabinet they discovered that there was a problem in their software that controls the sub amplifier. (Really? Do other EP600 owners know this?)

****
I'm wondering why Axiom hasn’t had a flood of complaints from EP600 owners. I know that I can't be the first guy to turn the sub volume past 1 or 2 o’clock and listen to deep bass movie soundtracks.

You wrote this in such a manner that it sounds as if each and every EP600 should be having the issues you experienced with your particular EP600 and this just isn't the case, there are many EP600 owners who have owned their subwoofers for years without any issues whatsoever ... including myself who is going on six trouble free years.

Jason and these other guys are just trying to lend a hand from their own experiences and others which have been posted on these boards that is almost always first attributed as being a bad speaker or other component when in fact many times it turns out to be something as simple as a bad or wrong connection, setting or bad cabling. Over the years we've seen it time and time again.

Sorry to hear about your particular 600 and I hope the 800 works out great for you. smile
_________________________
Rick
Our Room

smile

Top
#332833 - 12/30/10 11:07 AM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: da-drifter]
Jc Offline

aficionado

Registered: 06/27/06
Posts: 531
Loc: Sherbrooke, QC, Canada
Originally Posted By: da-drifter
. . . the EP600 currently has some negative issues.


Hi,
The issue which you have experienced was limited to only a few units and it has been fixed. Currently the EP600 has no issues and performs flawlessly in a spectacular fashion.
_________________________
jc

Top
#332899 - 12/30/10 07:23 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: Jc]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 18044
Loc: NoVA
JC, I volunteer to test the current EP600, just to make sure it's cool. You guys have my shipping address, right?

Actually, I think my wife would probably draw the line at that one...
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
#332918 - 12/30/10 11:43 PM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: Ken.C]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4872
Loc: Tulsa, Oklahoma
She wouldn't let you test it unless there was two of them to help smooth out the bass throughout the whole room?
_________________________
-David

Top
#332928 - 12/31/10 01:26 AM Re: IMPORTANT INFORMATION EP600 SUBWOFFER [Re: terzaghi]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 18044
Loc: NoVA
Well, yeah.
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
Page 3 of 3 < 1 2 3

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,404 Registered Members
16 Forums
24,320 Topics
430,797 Posts

Most users ever online:
2,082 @ 01/22/20 10:43 AM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13675
CV 11753
MarkSJohnson 11445
0 registered ()
273 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup