You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » Subwoofer problem

Topic Options
Rate This Topic
#336424 - 01/31/11 03:47 PM Subwoofer problem
sleves Offline
newbie

Registered: 01/31/11
Posts: 1
Hi there, i'm having problem with my subwoofer (ep350), for a couple of days now. It doesnot turn on. The red light is flashing and there is a intermittent clicking sound at the same time. I could not find any info on the troubleshoot page. Any clues?

Top
#336426 - 01/31/11 03:52 PM Re: Subwoofer problem [Re: sleves]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 18044
Loc: NoVA
Best to call or email Axiom.
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
#336436 - 01/31/11 04:59 PM Re: Subwoofer problem [Re: sleves]
Jc Offline

aficionado

Registered: 06/27/06
Posts: 525
Loc: Sherbrooke, QC, Canada
Hi Sleves,

Please, phone me using the Axiom's toll free number (1.866.244.8796); I will be glad to assist you.
_________________________
jc

Top
#336443 - 01/31/11 05:33 PM Re: Subwoofer problem [Re: Jc]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13571
Loc: Iowa
smile
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
Anthem AVM60 Outlaw 7700 Emotiva A500 Epson 5040UB



Top
#336501 - 02/01/11 02:05 AM Re: Subwoofer problem [Re: Jc]
fredk Offline
axiomite

Registered: 12/06/07
Posts: 7786
Loc: Canada
Who needs the lone de-ranger when you have JC to come to the rescue
_________________________
Fred

-------
Blujays1: Spending Fred's money one bottle at a time, no two... Oh crap!

Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,233 Registered Members
15 Forums
24,008 Topics
424,190 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13571
CV 11677
MarkSJohnson 11437
1 registered (CV)
180 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup