Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
EP600 Hum
#339198 02/19/11 07:56 PM
Joined: Dec 2005
Posts: 17
frequent flier
OP Offline
frequent flier
Joined: Dec 2005
Posts: 17
I've had my EP600 for a long time. Started buzzing recently. I doubt it's ground loop. Disconnected from the LFE input and plugged with a cheater plug and it's still humming. Removing the ground screw makes it much worse. any advice

The sub is out of warranty by about 2 months, if the amp needs replacing, any clue what they cost?

Re: EP600 Hum
Babyface #339207 02/19/11 09:49 PM
Joined: Sep 2008
Posts: 4,116
connoisseur
Offline
connoisseur
Joined: Sep 2008
Posts: 4,116
If you haven't made any changes to your system such as adding any new electronic components or cables and cheated the ground on the sub I highly doubt it is ground loop issue that is causing the humming. Does the sub still hum when there is no connection to the receiver, just plugged into the wall outlet?

It could very well be that the amp has kicked the bucket. Call support.


I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne
Re: EP600 Hum
BlueJays1 #339212 02/19/11 10:16 PM
Joined: Dec 2003
Posts: 10,420
J
shareholder in the making
Offline
shareholder in the making
J
Joined: Dec 2003
Posts: 10,420
If the sub still hums with only the eletrical power feed plugged into the wall then it is the amp and a call to Axiom should be done ASAP. I would hope they still cover it if it is just 2 months out of warranty or at least are very generous with costs.


Jason
M80 v2
VP160 v3
QS8 v2
PB13 Ultra
Denon 3808
Samsung 85" Q70
Re: EP600 Hum
jakewash #339213 02/19/11 10:27 PM
Joined: Jan 2004
Posts: 13,680
Likes: 1
shareholder in the making
Offline
shareholder in the making
Joined: Jan 2004
Posts: 13,680
Likes: 1
I agree, I hate it when electronics go kapooey 1-2 months after warranty. I swear manufacturers do this on purpose. smile I would call Axiom right away, they man the ones late.


M80s VP180 4xM22ow 4xM3ic EP600 2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800


Re: EP600 Hum
SirQuack #339214 02/19/11 10:47 PM
Joined: Dec 2005
Posts: 17
frequent flier
OP Offline
frequent flier
Joined: Dec 2005
Posts: 17
It's a light, persistent hum. It's there even if the sub is just plugged into the wall. I think I was wrong on the warranty. Apparently the amp is only 3 years? I bought it Christmas '05.

The sub seems to works fine other than the hum. It's just noticeable and kind of bothersome. I can't unhear it. Cheater plug does nothing. Turning it off and unplugging it are the only solutions. I honestly think it started after my circuit breaker clipped one time recently. It's faint enough that maybe I missed until recently, but like I said, I can't unhear it.

I've contacted support. Hopefully I can find a resolution.

Re: EP600 Hum
Babyface #339216 02/19/11 10:49 PM
Joined: Jul 2006
Posts: 11,794
Likes: 1
C
CV Offline
Founder, Axiom Upgrade Club
shareholder in the making
Offline
Founder, Axiom Upgrade Club
shareholder in the making
C
Joined: Jul 2006
Posts: 11,794
Likes: 1
Yeah, I hope they have a nice resolution for you. That hum would bother me a lot.

Re: EP600 Hum
Babyface #339224 02/19/11 11:21 PM
Joined: Jun 2006
Posts: 532
Jc Offline
aficionado
Offline
aficionado
Joined: Jun 2006
Posts: 532
Originally Posted By: Babyface
. . . I honestly think it started after my circuit breaker clipped one time recently . . .

Have you tried plugging it on a different circuit?


jc
Re: EP600 Hum
Jc #339226 02/19/11 11:36 PM
Joined: Dec 2005
Posts: 17
frequent flier
OP Offline
frequent flier
Joined: Dec 2005
Posts: 17
Originally Posted By: Jc

Have you tried plugging it on a different circuit?


Yes, it doesn't seem to matter.

Re: EP600 Hum
Babyface #339227 02/19/11 11:38 PM
Joined: Dec 2005
Posts: 17
frequent flier
OP Offline
frequent flier
Joined: Dec 2005
Posts: 17
I don't mind paying to replace the amp(too much). Hopefully it would be an updated version, as mine is a v1. Although I don't know if later versions shared the shape amp shape.

For now I just turn it off when I'm not watching TV. Just knowing it's there erks me though. Should be silent.

Re: EP600 Hum
Babyface #339235 02/20/11 12:52 AM
Joined: Jan 2004
Posts: 13,680
Likes: 1
shareholder in the making
Offline
shareholder in the making
Joined: Jan 2004
Posts: 13,680
Likes: 1
If it is under warranty I would assume you should not have to pay anything.


M80s VP180 4xM22ow 4xM3ic EP600 2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800


Page 1 of 2 1 2

Moderated by  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Link Copied to Clipboard

Need Help Graphic

Forum Statistics
Forums16
Topics24,358
Posts431,575
Members15,414
Most Online2,082
Jan 22nd, 2020
Top Posters
Ken.C 18,044
pmbuko 16,437
SirQuack 13,680
CV 11,794
MarkSJohnson 11,445
Who's Online Now
2 members (2x6spds, Mojo), 186 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Newsletter Signup
Powered by UBB.threads™ PHP Forum Software 7.7.4