Previous Thread
Next Thread
Print Thread
Rate Thread
M80 v3 bad driver
#391729 04/07/13 04:28 AM
Joined: Mar 2003
Posts: 144
GregLee Offline OP
veteran
OP Offline
veteran
Joined: Mar 2003
Posts: 144
Something seems to have come loose in the upper mid-range driver of one of my M80s. At least, that's my conclusion. I'll describe the symptoms below. I'll be calling Axiom technical support soon, I imagine, but I thought one of you might have a suggestion.

I've been hearing some harsh distortion sounds, occasionally, for a while. Piano music, women's chorals would sometimes do it. I had the impression it was coming from the left side, somewhere. I found a TV movie today, Prometheus, with 30 seconds of music that made the problem very prominent, and I started replaying it and putting my ear up to various speakers. I found it. It was coming from my left front, an M80 v3 I bought 2+ years ago. More specifically, from the driver right under the two tweeters.

I found that if I pressed lightly on the right exterior of the cone the distortion went away -- mostly anyway. So I put in place a temporary fix. I have a rolled up piece of cotton gauze pressing against the cone secured by a long piece of Scotch tape across the front of the cabinet (behind the grill). It sounds much better now.

So, it's no longer an urgent problem, but I ought to do something more permanent. I have never had the M80 apart, so I have no idea what's inside.


Greg
VP180, M80s, M22s, QS8(4), CSW S305s, EP500, Pioneer VSX-90
M2i, M3(2), Pio vsx-1020
Re: M80 v3 bad driver
GregLee #391730 04/07/13 04:39 AM
Joined: Jul 2009
Posts: 2,281
connoisseur
Offline
connoisseur
Joined: Jul 2009
Posts: 2,281
Its probably just the voice coil rubbing, very tight tolerence there. Contact Brent at Axiom on Monday and they will ship out a new driver , faster than fast. Funny how these things seem to happen on a weekend.

Just a thought , try just loosening the 4 screws and then retighten, see if it clears up.


DOG is GOD spelled backwards.
What others think of me is none of my business.
M80 V3 MY GLOSS Cherry
Re: M80 v3 bad driver
GregLee #391732 04/07/13 11:17 AM
Joined: Sep 2004
Posts: 11,451
shareholder in the making
Offline
shareholder in the making
Joined: Sep 2004
Posts: 11,451
I concur.


::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::
Re: M80 v3 bad driver
GregLee #391733 04/07/13 01:47 PM
Joined: Jan 2004
Posts: 13,707
Likes: 1
shareholder in the making
Offline
shareholder in the making
Joined: Jan 2004
Posts: 13,707
Likes: 1
I would check the fasteners to make sure they are snug, just for the fact when you applied pressure to the outer edge it went away.


M80s VP180 4xM22ow 4xM3ic EP600 2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800



Moderated by  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Link Copied to Clipboard

Need Help Graphic

Forum Statistics
Forums16
Topics24,490
Posts434,487
Members15,439
Most Online2,082
Jan 22nd, 2020
Top Posters
Ken.C 18,044
pmbuko 16,437
SirQuack 13,707
CV 11,911
MarkSJohnson 11,451
Who's Online Now
1 members (BBIBH), 222 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Newsletter Signup
Powered by UBB.threads™ PHP Forum Software 7.7.4