Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Axiom’s New Computer Speakers

Blind Listening Tests

Sneak Peek into Axiom’s Current Research and Development

Wall'O'Fame
Solarrdadd's 7.1 Apartment HT!
A promise is A promise... Axiom's second home
Who's Online
2 registered (Serenity_Now, Ken.C), 35 Guests and 10 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13360 Members
11 Forums
23078 Topics
408058 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17843
pmbuko 16319
SirQuack 13356
CV 11388
MarkSJohnson 11061
Meanwhile On Facebook

(y) That countdown timer is finally off their site! Great to see high-quality s...

⚠ Only 5 days left in our Computer Speaker Presale! http://www.axiomaudio.com/c...

(y) Love this review a customer sent us recently: "Bottom line, these speakers...

❔ The new M1 High Powered Computer Speaker uses Axiom's latest full one-inch twe...

Topic Options
Rate This Topic
#394955 - 07/08/13 03:43 PM EP 600 Popping
mastaplaya Offline
old hand

Registered: 11/20/07
Posts: 89
Loc: Cold Lake AB
Hi guys wondering what input you might have on my problem?

I have two EP 600's daisy chained together. the first sub in the daisy chain has recently started popping randomly even when there is no signal input to it. I'm thinking it's an amp issue. I am using axiom cables to connect it to the Denon 4308 receiver. the downstream sub has no issues and works flawlessly.

I have had this setup for over 5 yrs and it has been nothing short of amazing until now. I was hoping you guys/gals would have some simple suggestions for me before I contact Axiom. anyone have similar problems?

Top
#394956 - 07/08/13 03:53 PM Re: EP 600 Popping [Re: mastaplaya]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1846
i dont have a similar problem. but, if i were in your aituation i would check the cabling. use the cables that go to the second aub with the first sub...


i so have 2 EP-600's. i am using a Y RCA connector out of my processor, then each sub recieves it's own RCA input.


Good luck.

Top
#394957 - 07/08/13 05:02 PM Re: EP 600 Popping [Re: mastaplaya]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 11061
Loc: Central NH
Try unplugging each of them for 5 minutes to reset them.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#394963 - 07/08/13 09:53 PM Re: EP 600 Popping [Re: mastaplaya]
BlueJays1 Offline
connoisseur

Registered: 09/19/08
Posts: 4092
Loc: Porch,enjoying Bombay Sapphire
Originally Posted By: mastaplaya
Hi guys wondering what input you might have on my problem?

I have two EP 600's daisy chained together. the first sub in the daisy chain has recently started popping randomly even when there is no signal input to it. I'm thinking it's an amp issue. I am using axiom cables to connect it to the Denon 4308 receiver. the downstream sub has no issues and works flawlessly.

I have had this setup for over 5 yrs and it has been nothing short of amazing until now. I was hoping you guys/gals would have some simple suggestions for me before I contact Axiom. anyone have similar problems?


Personally I would just leave it unplugged until you get a response from customer service.

The popping sounds could very well be due to a capacitor or some other part that might need to get serviced in the amplifier section.
_________________________
I’m armed and I’m drinking. You don’t want to listen to advice from me, amigo.

-Max Payne

Top



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.