Previous Thread
Next Thread
Print Thread
Rate Thread
EP 350 Sub Making Roaring Sound
#395157 07/16/13 02:07 AM
Joined: Oct 2007
Posts: 15
K
KSTx Offline OP
frequent flier
OP Offline
frequent flier
K
Joined: Oct 2007
Posts: 15
My sub has started making a roaring noise lately that makes it useless to have on. What is wrong and what can be done to fix it? Need help on this.

Re: EP 350 Sub Making Roaring Sound
KSTx #395158 07/16/13 02:09 AM
Joined: Oct 2007
Posts: 15
K
KSTx Offline OP
frequent flier
OP Offline
frequent flier
K
Joined: Oct 2007
Posts: 15
By the way it is approximately 3 years old.

Re: EP 350 Sub Making Roaring Sound
KSTx #395159 07/16/13 02:33 AM
Joined: Jan 2004
Posts: 13,682
Likes: 1
shareholder in the making
Offline
shareholder in the making
Joined: Jan 2004
Posts: 13,682
Likes: 1
when you unplug the RCA coax line in, but leave the power connected does it still make the noise? Also, what if you unplug the AC for a few minutes and then plug it back in, do you still have the noise?


M80s VP180 4xM22ow 4xM3ic EP600 2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800


Re: EP 350 Sub Making Roaring Sound
SirQuack #395756 08/03/13 06:18 PM
Joined: Oct 2007
Posts: 15
K
KSTx Offline OP
frequent flier
OP Offline
frequent flier
K
Joined: Oct 2007
Posts: 15
I had the sub on and it was making the roaring sound, I unplugged the line in and yes it still made the sound.

Re: EP 350 Sub Making Roaring Sound
KSTx #395757 08/03/13 06:39 PM
Joined: May 2003
Posts: 18,044
shareholder in the making
Offline
shareholder in the making
Joined: May 2003
Posts: 18,044
Probably a bad cap. Call Axiom.


I am the Doctor, and THIS... is my SPOON!
Re: EP 350 Sub Making Roaring Sound
Ken.C #395759 08/03/13 07:12 PM
Joined: Oct 2007
Posts: 15
K
KSTx Offline OP
frequent flier
OP Offline
frequent flier
K
Joined: Oct 2007
Posts: 15
I sent an email to them and have not heard back. I guess I'll have to phone like you said.
Thanks.

Re: EP 350 Sub Making Roaring Sound
KSTx #395762 08/04/13 01:33 AM
Joined: May 2002
Posts: 10,644
shareholder in the making
Offline
shareholder in the making
Joined: May 2002
Posts: 10,644
Kim, you didn't say if you also unplugged the power cord for a few minutes. This might not be the type of sound that this would cure(a couple days ago a thumping noise in another thread was stopped by unplugging to reset the sub amp), but you should give it a try anyway if you haven't already done so.


-----------------------------------

Enjoy the music, not the equipment.


Re: EP 350 Sub Making Roaring Sound
KSTx #398215 10/27/13 06:50 PM
Joined: Oct 2007
Posts: 15
K
KSTx Offline OP
frequent flier
OP Offline
frequent flier
K
Joined: Oct 2007
Posts: 15
Axiom called and I boxed up the amp out of the unit and shipped it off. It is supposed to be on its way back now. Waiting to re-install it.


Moderated by  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Link Copied to Clipboard

Need Help Graphic

Forum Statistics
Forums16
Topics24,362
Posts431,677
Members15,414
Most Online2,082
Jan 22nd, 2020
Top Posters
Ken.C 18,044
pmbuko 16,437
SirQuack 13,682
CV 11,797
MarkSJohnson 11,450
Who's Online Now
1 members (CV), 238 guests, and 4 robots.
Key: Admin, Global Mod, Mod
Newsletter Signup
Powered by UBB.threads™ PHP Forum Software 7.7.4