You are not logged in. [Log In]


Forums » AxiomAir Discussion » AxiomAir General Discussion » Problems always on Friday when cust sppt is gone

Topic Options
Rate This Topic
#427369 - 12/08/17 05:51 PM Problems always on Friday when cust sppt is gone
chesseroo Offline
axiomite

Registered: 05/13/02
Posts: 5197
Loc: western canada
A little help from anyone else with an Axiom Air?

I plugged the unit in this afternoon to get it powered up. It has been sitting in a box for about a month (testing it before it gets handed out as a gift).

I went to startup the Air after plugging it in and got no joy. No lights. The unit was working fine when i first got it a month ago.
Thinking there is something wrong with the Air, i tried a few variations to turn it on like holding the power button down for a few seconds rather than a quick press.
Nothing.

I checked the power cables and one was 'a bit' loose (the main three prong going into the transformer) so i made sure it was tight and tried turning on the power again.
Nothing.

Then i noticed on the power brick there is a little LED light. I noticed that LED light is not on when the brick is plugged in (assuming it is a light of course).
Can someone confirm if this light is on for their Air when plugged in?
If yes, then i would suspect i have a dead power brick and as such, cannot do squat with the Air until sometime next week after contacting customer support.

[sigh]
Always a problem on a Friday evening when business is closed.

Given the nature of the problem there is no other way to charge the Air. Something new to add to a wish list.
It would be nice if there was a universal charger that i could hook up to this thing. I could drive to Best Buy and have a new charger in about 10 minutes. Or even a USB trickle charge. It might be slow, but it's better than having to wait 4+ days until a new power brick could possibly arrive.
Any thoughts that anyone else knows about?


Edited by chesseroo (12/08/17 05:53 PM)
_________________________
"Those who preach the myths of audio are ignorant of truth."

Top
#427399 - 12/10/17 02:33 AM Re: Problems always on Friday when cust sppt is gone [Re: chesseroo]
Ian Offline
President
connoisseur

Registered: 03/13/01
Posts: 1200
The green LED on the power brick should be on when it is plugged into the wall socket.
_________________________
Ian Colquhoun
President & Chief Engineer

Top

Moderator:  Andrew, Debbie, Ian, Jc 
Forum Stats

15,281 Registered Members
16 Forums
24,088 Topics
425,371 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13579
CV 11709
MarkSJohnson 11444
1 registered (RLS)
188 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup