Get Free, Friendly, Expert Advice
Call 1-888-352-9466 or email

Designed and Manufactured in Canada Since 1980

Axiom Dolby Atmos 7.2.4 Cinema
Solarrdadd's 7.1 Apartment HT!
AxiomAudio Blog

Insider’s Sneak Peek: AxiomAeris

Axiom’s New Computer Speakers

Blind Listening Tests

Who's Online
1 registered (exlabdriver), 108 Guests and 5 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
13,398 Registered Members
11 Forums
23,277 Topics
412,476 Posts

Most users ever online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17962
pmbuko 16378
SirQuack 13358
CV 11520
MarkSJohnson 11245
Meanwhile On Facebook
Topic Options
Rate This Topic
#6505 - 10/20/02 05:00 PM EP125 buzzing sound
Patchwork Offline

Registered: 09/23/02
Posts: 199

I have tried Alan's tip to plug in speaker cables into the high level in and remove the line level and see if there is still the buzzing sound. There is.

Has anyone done anything to get rid of this sound? I feel it is getting louder which is why I tried to take care of it now.

thank you for any advice

#6506 - 10/20/02 08:44 PM Re: EP125 buzzing sound
john_henderson Offline

Registered: 09/03/02
Posts: 186
Before we get into a whole bunch of diagnostics. Some questions;

A. When you say a buzzing, is this a kind of hi pitched buzzing noise, or more of a hum?
B. When you are very close to the unit, does the noise sound like it is coming more from the back of the unit. Or is it a hum that you hear from the woofer, and if it is more of a hum, is it effected by increasing or decreasing the volume control on the sub.

The buzzing if this is what it is, and it that sounds like it is coming more from the rear of the sub could be a noisy transfromer in the sub power supply. The fix for that would be to call Joe in service and arrange to either send it back or have Joe send you a new part and you would return the defective one after you replace the unit.

#6507 - 10/20/02 11:49 PM Re: EP125 buzzing sound
Patchwork Offline

Registered: 09/23/02
Posts: 199
yes, the humming is from the power supply

I will call Joe. I figured there was a fix for this.

Thank you.


Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2015 Colquhoun Audio Laboratories Limited
All Rights Reserved.