AxiomAir won't start up after 2.10.1 upgrade

Posted by: elsewhere

AxiomAir won't start up after 2.10.1 upgrade - 03/11/19 10:27 AM

Hey guys,

I need some help. After updating to 2.10.1, I turned off the Air and then powered up. I see the green light but I never get to the startup chimes. How do I troubleshoot this? It's been 20 min since the power up.
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/11/19 06:00 PM

Hi everywhere,

If you tap the power button does your AxiomAir shut off in about 20 seconds?
Posted by: hoopaslotche

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/12/19 05:35 PM

I'm in a similar boat - my 2.10.1 and 2.10.2 upgrades went well; but after the 2.10.3 upgrade I also see a green light and never get to hear the startup chimes. It shuts off in less than 20 seconds.

Please advise how to troubleshoot and fix. Thanks.
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/13/19 12:37 AM

Can you try the following and let me know if your AxiomAir comes back to life:

1. Format a USB drive between 4g and 32g with FAT32
2. Download this link to your computer: https://s3.amazonaws.com/axiom-air-install-files/AxiomAirV2/AxiomAir-V2103-Update.zip
3. Extract the downloaded file to the USB drive
4. Power down your AxiomAir
5. Plug the USB drive into any of your AxiomAir USB ports
6. Turn on your AxiomAir and wait for 5 minutes
7. Check to see if you are on version 2.10.3
8. Power down your AxiomAir and remove the USB drive
Posted by: elsewhere

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/13/19 04:25 PM

Thanks I will try this tonight
Posted by: elsewhere

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/14/19 11:29 AM

So here is what I did. I downloaded the zip file. It contained only 1 .fir file which I assume is the firmware. I turned off my Air and then pulled out the WLAN usb and put in the USB stick that is formatted 2 gb FAT and had the .fir file on it. I connected it by ethernet cable and powered it on. I did not hear any start up chimes but I saw the green on indicator light. I left it alone all night. This morning I tried to connect to it using my AxiomAir app on my iphone and could not. I turned off the Air and turned it back on after waiting 5 seconds. I left it alone for an hour. I did not hear any startup chimes and I cannot connect to it using my iphone app.

It looks like my Air is dead frown What do I do now?
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/14/19 12:37 PM

Looks like we will have to get serious now, LOL. I will PM you the instructions to reflash your SD Card.
Posted by: hoopaslotche

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/14/19 09:07 PM

Ian - I've worked through the list in post #431583 with no success; my Air is dead too. Thx in advance for the SD reflash instructions.
Posted by: elsewhere

Re: AxiomAir won't start up after 2.10.1 upgrade - 03/16/19 02:10 PM

Hi All! Just posting an update. I reflashed according to Ian's directions.
My only quirk was that I had to power down and start two times in a row before I could play any music through the wifi connection even though I can see I am connected.

I'm now on 2.10.3 and the AxiomAir is working perfectly. I love this thing! smile .
Posted by: leehaver

Re: AxiomAir won't start up after 2.10.1 upgrade - 09/28/19 07:40 PM

Hi Ian,
I'm in the same boat after trying to update to 2.10.3, green power light only for days, no blue light. Please help. Thanks
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 10/01/19 12:45 AM

Hi leehaver,

I will PM you the instructions to reflash you SD Card. This should bring you back to life.
Posted by: scout

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/14/19 02:32 PM

And now for me, with the latest update. I was on 2.10.4 toasted macadamia from 10/21, did the check for updates, it found one and updated and asked to restart and now nothing but a solid green light. Retried a few times and downloaded 2.10.3 to usb to try a rollback, but nada.
Posted by: Mojo

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/14/19 03:13 PM

I would never, ever install any version with the word "toasted" in it.
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/15/19 06:08 AM

This is very odd. I have done the update to 2.12.1 Toasted Pinecone on both Version 1 and Version 2 AxiomAirs. All I can think is some odd interruption happened. It might take an SD Card reflash to bring it back to life. What model do you have?
Posted by: scout

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/15/19 11:11 AM

It's an N3 - got it pretty early on. SN 4710...
Posted by: Ian

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/16/19 01:01 PM

Here are the instructions to reflash your SD Card:

1. Download the card flash software here www.etcher.io
2. Download this link https://s3.amazonaws.com/axiom-air-insta...3-10-pi.img.zip
3. Shut down your AxiomAir
4. Remove all dongles from the USB ports
5. Remove the large bottom door from your AxiomAir
6. Remove the SD Card from the Micro Computer mounted to this door
7. Plug the SD card into your computer
8. In Etcher select the download above where it says Select Image
9. In Etcher select the drive with the SD card in it for Select Drive (it is likely Etcher will find it for you)
10. In Etcher hit Flash
11. After it is downloaded reinstall the SD Card in your AxiomAir and put the door back on
12. Plug an Ethernet cable into your AxiomAir
13. Turn on your AxiomAir
14. You will get a loud “Quality Control Passed” (v2 products only) followed by the xylophone
15. Wait for 30 seconds after the xylophone
16. Open the AxiomAir App and tap the gear in the upper right, then System, and verify you are on Version 2.10.3
17. Tap the gear again and then Network. About half way down the page you will see your home network listed (if you see both a 5g and a regular one, choose the regular one), then tap the connect icon beside your network. You will be prompted to enter your home network password, after it is entered hit the connect icon beside your password
18. Shut down your AxiomAir
19. Unplug the Ethernet cable
20. Turn your AxiomAir back on
21. Verify the AxiomAir UI resolves. If not shutdown your AxiomAir plug in the WiFi dongle and turn it back on.
22. If you would like to use Bluetooth plug in a 4.0 Bluetooth Dongle for LINUX to any of the USB ports.
23. You are now able to use the Update button on the System page to get the latest version
Posted by: SRoode

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/16/19 07:57 PM

Ian, it's not me going through this, but I wanted to say thanks for taking YOUR OWN TIME to make this right.
Posted by: Mojo

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/16/19 10:18 PM

Steve, do you know the story behind those instructions? Ian typed them out on this board while he was snow-mobiling. I am sure there's a photo of him somewhere steering with his feet, typing away, while flying through Algonquin Park.
Posted by: scout

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/16/19 11:31 PM

Thanks for the fast feedback. I tried once with no success -- same green light only. I'll give it another fresh attempt tomorrow and see if I get better luck. I do have >1 air system, so there may be some debugging I can do by swapping out parts.
Posted by: Mad Beggar

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/17/19 04:42 AM

You can also download the full 2.12.1 image at https://axiom-air-install-files.s3.amazo...2-11-pi.img.zip
Flashing that onto your SD card will bring you directly to the latest release.
Let us know if you require any additional assistance.
Posted by: Shawzy44

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/17/19 04:49 AM

I left the AA after restart for well over 30mins. It didn’t come back to life. What’s your recommended next step?
Posted by: Andrew

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/17/19 07:36 AM

Originally Posted By Shawzy44
I left the AA after restart for well over 30mins. It didn’t come back to life. What’s your recommended next step?


If the green power LED is still on, hold the power button down until the LED goes out. Then wait a few seconds and press the power button again. If it does not re-boot you can follow the instructions above to re-program your SD card.
Posted by: scout

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/17/19 04:15 PM

That worked! It ALL works! I'm flooded with sound!
Posted by: SRoode

Re: AxiomAir won't start up after 2.10.1 upgrade - 12/17/19 07:50 PM

The only problem I have with the AxiomAir is an almost instantaneous dropout when I stop playing music using AirPlay. I plugged a Bluetooth dongle in it for now to keep the music going during parties, but of course the quality is not as good as WiFi. Hoping this will be fixed eventually.