Posted by: spiffnme

RAID Hell - 07/19/13 01:12 PM

U guys usually have an answer for everything, so how about some tech support? LOL!

I moved my workstation to a new facility and upon bootup, I was greeted with a warning that multi-bit ECC errors had been detected on my RAID controler. It suggested the DIMM be replaced less I risk likely corrupt data.

So, I ordered a new DIMM. Installed the DIMM, boot up gave me the same exact error message. Whaa??

Borrowed another controller card (Dell perc H800, same as my bad one) and everything booted up a-ok, but it no longer sees my RAID configuration at all.

Any ideas how I can get my data back?

PS - this is even weirder...the RAID control management software seems to be gone as well. Anyone have a link to where I can re-download it? I believe it was LSI megaRAID software?
Posted by: spiffnme

Re: RAID Hell - 07/19/13 01:26 PM


Win7 Ultimate 64-bit - os
ASUS Z9PE-D8 WS - motherboard
Intel E5-2650 (x2) - cpus
32GB Kingston KVR16R11D4K4/32 - system memory
ASUS GTX 690 4GD5 - graphics card
Dell Perc H800 RAID controller
Seagate 3TB (x8) drives in Sans Digital TR8X+BP enclosure
Posted by: ClubNeon

Re: RAID Hell - 07/19/13 01:36 PM

That's likely to be a fault in the RAID controller itself, or likely the DIMM slot. Try some air in a can to blow it out, and then insert/remove the DIMM a few times.

Go back to the old RAID controller, and see if there's a way to back up the RAID config, write it to the disks. At least document all the settings. Hopefully the replacement controller will allow you recreate an array, without initializing it.

But try cleaning the old controller first.

What management software are you talking about?
Posted by: spiffnme

Re: RAID Hell - 07/19/13 01:40 PM

We tried the old card several times. Re-seated the DIMM (old one and new one) as well as the card itself on the MB. Always barks about ECC errors at boot up.

LSI MegaRAID is the software I'm looking for a download link for.
Posted by: ClubNeon

Re: RAID Hell - 07/19/13 01:58 PM

I mean the BIOS settings? I don't see how the Windows software would have just disappeared. It may not be auto-starting because there's no configured array.

The text-mode settings can be disabled on the card. It used to be you could use a floppy to get into the card and re-enable it. I wonder if you put both cards in at the same time, if you can change the settings on the new from the old.
Posted by: Ken.C

Re: RAID Hell - 07/19/13 02:03 PM

The new card should have a Foreign configuration setting in the card BIOS, if it's seeing the drives at all. Look at that tab, and then import the foreign config, and Bob's your uncle.
Posted by: pmbuko

Re: RAID Hell - 07/19/13 02:12 PM

RAID configuration data is written to NVRAM on the controller, but there's also information on the disks themselves that can help you recover the proper configuration. Page 27 and 28 of this manual seems to suggest the the H800 controller should automatically detect the configuration data on your drives and offer to import that configuration for you. This isn't happening?

As a last resort -- and this will only work if you remember exactly how your RAID was configured -- you can manually recreate the configuration on the new card, but choose NOT to initialize/format the disks. I've had to do this a couple times and things worked out well.
Posted by: spiffnme

Re: RAID Hell - 07/19/13 03:09 PM

Foreign config is grayed out.

Config in bios sees all drives, but as 2gb drives (they are 3tb each)
Posted by: ClubNeon

Re: RAID Hell - 07/19/13 03:17 PM

Do both controllers have the same firmware revision? Drives over 2TB can have issues, especially with older controllers.
Posted by: pmbuko

Re: RAID Hell - 07/19/13 05:06 PM

Good catch on the firmware version. Download an update here:

You might want to put the card back in the other machine and update it from there, as you'll need a working OS to run the update from.
Posted by: spiffnme

Re: RAID Hell - 07/19/13 06:27 PM

updated new card with same firmware that the last card had. No dice. Still doesn't recognize my RAID config.
Posted by: spiffnme

Re: RAID Hell - 07/19/13 07:19 PM

got LSI MegaRAID Storage Manager installed and it too sees the drives as 2TB. It scanned for a foreign configuration and came up with nothing.

I've reached the point where I'm ok with losing the data if I can just get this rebuilt, I'll start re-rendering my files. Problem now is the 2tb/3tb issue. What next?
Posted by: pmbuko

Re: RAID Hell - 07/19/13 11:15 PM

Are the drives showing up at 2tb in controller's bios screen or after the os is loaded? I'm pretty sure the very first version of the H800 supported 3tb drives.

I is confused.
Posted by: ClubNeon

Re: RAID Hell - 07/20/13 12:18 AM

Yeah, I'm stumped too.

Are these SATA or SAS drives? Shouldn't even matter though, since the original card could see them as 3TB, the replacement should too.
Posted by: Ken.C

Re: RAID Hell - 07/20/13 06:31 AM

All I can think is that the enclosure itself is the issue.
Posted by: CatBrat

Re: RAID Hell - 07/21/13 05:12 PM

Or maybe it's something inside the enclosure.
Posted by: spiffnme

Re: RAID Hell - 07/24/13 02:00 PM

oddly enough, put old card back in (with the new DIMM), booted in 'safe mode' and it came up without errors. Rebooted several times in normal mode and still no problems. Whatever. smile
Posted by: MarkSJohnson

Re: RAID Hell - 07/24/13 02:24 PM

:: fingers crossed ::