EP350 subwoofer connection issue

Posted by: chuck122

EP350 subwoofer connection issue - 12/31/16 05:17 PM

My wife moved my prize subwoofer and snapped off the line in female subwoofer connecter input . Other than shipping the 350 back for service how can I connect my subwoofer cable to the 350? The output from my pioneer elite is via a subwoofer cable.
thanks!
Posted by: Jc

Re: EP350 subwoofer connection issue - 12/31/16 05:42 PM

Hi,

On your subwoofer, use the output connector instead of the input one. If there is no internal damage, it will work perfectly and performance wise it will be identical as if you were using the input one.
Posted by: SirQuack

Re: EP350 subwoofer connection issue - 12/31/16 07:06 PM

Yep as JC mentioned. Some people use these jacks to "daisy chain" multiple subs together. If the other one is not damaged you should be fine.
Posted by: Mojo

Re: EP350 subwoofer connection issue - 01/01/17 12:52 AM

Jc's and Randy's advice is pure hogwash!

Tell your wife she busted your sub and you need a new one (EP800). smile
Posted by: Jc

Re: EP350 subwoofer connection issue - 01/01/17 02:36 PM

True, I stand corrected . . .

The perfect solution !

Happy New Year !
Posted by: chuck122

Re: EP350 subwoofer connection issue - 01/01/17 06:16 PM

Thanks so much. I bought a new cable with male to male terminals and it works like she never even broke it. Since I can't justify a new sub I'll need to make my wife provide my restitution in other ways. Happy New Year.