Get Free, Friendly, Expert Advice
Call 1-888-352-9466 or email

Designed and Manufactured in Canada Since 1980


Wall'O'Fame
Solarrdadd's 7.1 Apartment HT!
A promise is A promise... Axiom's second home
AxiomAudio Blog

Insider’s Sneak Peek: AxiomAeris

Axiom’s New Computer Speakers

Blind Listening Tests

Who's Online
2 registered (Socketman, oakvillematt), 67 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13,380 Registered Members
11 Forums
23,218 Topics
411,209 Posts

Most users ever online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17932
pmbuko 16357
SirQuack 13357
CV 11473
MarkSJohnson 11200
Meanwhile On Facebook
Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#213062 - 06/25/08 10:45 PM EP500 Has Red Light - How to Fix/Send for service?
Khan Motorsport Offline
old hand

Registered: 11/10/07
Posts: 61
Loc: Toronto, Canada
I don't know why it happened, but my EP500 doesn't seem to be working and the light on the back lights up as red.

Is there any thing i can do to fix this at home or do I have to send it in? What's the warrenty period on these things anyhow? 1 year? 30 days?


Thanks
_________________________
-Omar
Team Mischief

Top
#213066 - 06/25/08 11:38 PM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: Khan Motorsport]
nickbuol Offline
connoisseur

Registered: 09/16/04
Posts: 4753
Loc: Marion, IA
Have you tried calling Axiom? They are known for outstanding customer service and you may get a result faster calling the experts there than waiting for the "experts" here.

I'd help you out, but I don't have an EP500.
_________________________
http://ht.buol.us
2-M60s, VP180, VP150, 4-QS8s, 4-M3s, SVS 20-39PCi, DIY Sub, 8-Shakers, JVC RS45

Top
#213085 - 06/26/08 01:19 AM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: nickbuol]
anthony11 Offline
local

Registered: 04/15/08
Posts: 267
Loc: Seattle WA
One needs a metric telephone to call Canada, though, right? ;\)

Top
#213095 - 06/26/08 03:00 AM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: anthony11]
BrenR Offline
connoisseur

Registered: 12/10/03
Posts: 3602
Loc: Winnipeg MB Canada
 Originally Posted By: anthony11
One needs a metric telephone to call Canada, though, right? ;\)
Yes, ours go 0-9, not 0-11.

Bren R.

Top
#213098 - 06/26/08 08:11 AM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: BrenR]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4859
Loc: Tulsa, Oklahoma
a fuse maybe?
_________________________
-David

Top
#213105 - 06/26/08 09:50 AM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: terzaghi]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13357
Loc: Iowa
800 Axiom
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#213138 - 06/26/08 12:35 PM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: SirQuack]
fredk Offline
axiomite

Registered: 12/06/07
Posts: 7539
Loc: Canada
If you do that here, Peter will answer.
_________________________
Fred

-------
Blujays1: Spending Fred's money one bottle at a time, no two... Oh crap!

Top
#213140 - 06/26/08 12:41 PM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: fredk]
Khan Motorsport Offline
old hand

Registered: 11/10/07
Posts: 61
Loc: Toronto, Canada
called axiom,
very nice people as i would expect.
the tech support fella suggests that i replace the fuses that were in there (250mA) with 1A slow blow fuses because even though they look fine, they might still have no conductivity.

going to try that and see.
_________________________
-Omar
Team Mischief

Top
#213204 - 06/26/08 06:46 PM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: Khan Motorsport]
nickbuol Offline
connoisseur

Registered: 09/16/04
Posts: 4753
Loc: Marion, IA
Ah, a multimeter would be your friend here... But, grab those fuses and give us an update on the prognosis...
_________________________
http://ht.buol.us
2-M60s, VP180, VP150, 4-QS8s, 4-M3s, SVS 20-39PCi, DIY Sub, 8-Shakers, JVC RS45

Top
#213509 - 06/28/08 04:15 PM Re: EP500 Has Red Light - How to Fix/Send for service? [Re: nickbuol]
Khan Motorsport Offline
old hand

Registered: 11/10/07
Posts: 61
Loc: Toronto, Canada
replaced all the fuses. Red light is still on.
will call axiom CS again after it opens.
_________________________
-Omar
Team Mischief

Top
Page 1 of 2 1 2 >

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2015 Colquhoun Audio Laboratories Limited
All Rights Reserved.