Get Free, Friendly, Expert Advice
Call 1-888-352-9466 or email

Designed and Manufactured in Canada Since 1980


Wall'O'Fame
Axiom Dolby Atmos 7.2.4 Cinema
Solarrdadd's 7.1 Apartment HT!
AxiomAudio Blog

Insider’s Sneak Peek: AxiomAeris

Axiom’s New Computer Speakers

Blind Listening Tests

Who's Online
2 registered (Dundas, MarkSJohnson), 109 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13,449 Registered Members
11 Forums
23,364 Topics
413,684 Posts

Most users ever online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17994
pmbuko 16400
SirQuack 13360
CV 11547
MarkSJohnson 11293
Meanwhile On Facebook
Page 3 of 3 < 1 2 3
Topic Options
Rate This Topic
#380482 - 07/20/12 11:41 PM Re: EP350 Humming After I Moved Homes [Re: gog]
gog Offline
regular

Registered: 07/17/12
Posts: 9
Oh god that was it, unplugged the ground screw and the hum is gone. Been racking my brains on this for days lol. If only the first pic showed the entire back panel... Thanks for all the help guys, never would've figured that out with out you. smile


Edited by gog (07/20/12 11:42 PM)

Top
#381175 - 08/05/12 10:27 AM Re: EP350 Humming After I Moved Homes [Re: gog]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 17994
Loc: NoVA
I'm mistaken--my EP350 amp DOES have a ground screw. It's just hard to spot.
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
Page 3 of 3 < 1 2 3

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2015 Colquhoun Audio Laboratories Limited
All Rights Reserved.