Originally Posted By: Micah
But who in the hell would buy a speaker called the VP166.6???


The same people who use Ubuntu Satanic Edition ?


Edited by bridgman (04/30/10 11:42 PM)
_________________________
M60ti/VP180/QS8, SVS PC-Plus 20-39, EP500
M5HP, Sierra-1, M40ti
M2ti, M3v4, VP100