Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Blind Listening Tests

Sneak Peek into Axiom’s Current Research and Development

Axiom’s Newest Speaker: The In-Ceiling M3

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
1 registered (Ken.C), 43 Guests and 7 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13330 Members
11 Forums
22922 Topics
405251 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17791
pmbuko 16289
SirQuack 13341
CV 11237
MarkSJohnson 10942
Meanwhile On Facebook

☺ Wow - our 13,000 likes! Awesome! #thankful

Did you get your "Golden Email"? The great gift certificate email giveaway star...

Here's a helpful article for everyone looking at putting a new stereo or home th...

Interesting article about who's getting the money from streaming radio services...

Topic Options
Rate This Topic
#145948 - 08/22/06 06:12 AM Stereo Amplifier Problem
wes Offline
newbie

Registered: 08/22/06
Posts: 3
I have been given a faulty Mitsubihi DA-U680 Stereo Amplifier for free. Before I consider the possibility of paying for a repair perhaps someone of a technical nature would offer an opinion for the following fault condition.

1. The unit powers up OK
2. There is no smell or outwood damage.
3. If I turn up the volume both channels increase in sound and the leds increase in range.
4. There is a very small content of the source recording being played but very small indeed.
5 But there is a white noise coming from both channels which is controled by the volume but is very much a fault condition.

Any ideas please.

Top
#145949 - 08/22/06 08:00 AM Re: Stereo Amplifier Problem [Re: wes]
bridgman Offline
axiomite

Registered: 08/25/04
Posts: 5433
Loc: Bowmanville, Ontario, Canada
>>and the leds increase in range

I didn't have time to look up your amplifier model on the internet, but are you saying that the LEDs which indicate output power/signal level are flashing higher as if more sound was coming out ?

If so, that has to be a helpful piece of info...

Top
#145950 - 08/22/06 10:57 AM Re: Stereo Amplifier Problem [Re: wes]
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
Have you tried all outputs, phono,aux, ect., I had the same problem with one of my old pioneer receivers so I switched my devices output and tha cleared up the problem.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#145951 - 08/23/06 03:11 AM Re: Stereo Amplifier Problem [Re: bridgman]
wes Offline
newbie

Registered: 08/22/06
Posts: 3
Thank you for your input...The LEDs do indeed light the more I increase the volume..but then so does the motor boat white noise.


Edited by wes (08/23/06 03:15 AM)

Top
#145952 - 08/23/06 03:13 AM Re: Stereo Amplifier Problem [Re: HomeDad]
wes Offline
newbie

Registered: 08/22/06
Posts: 3
Yes I did try the other input sockets without any change in the fault....many thanks for the reply though.


Edited by wes (08/23/06 03:14 AM)

Top
#145953 - 08/23/06 08:44 AM Re: Stereo Amplifier Problem [Re: wes]
bridgman Offline
axiomite

Registered: 08/25/04
Posts: 5433
Loc: Bowmanville, Ontario, Canada
If the amplifier has pre-out and power-amp-in connections and you can borrow a second amplifier or receiver which also has those connections you should be able to localize the problem to either the preamp or power amp section by pairing one portion of your amp with the other portion of the borrowed amp/receiver.

Having said that it sure sounds as if the problem is in the pre-amp section.

Top
#145954 - 09/01/06 05:05 PM Re: Stereo Amplifier Problem [Re: wes]
BruceH Offline
devotee

Registered: 07/12/05
Posts: 353
Loc: Western Canada (just)
Last time I had a Mitsubishi amplifier that exhibited those symptoms it turned out to be a cracked circuit board near the power transformer. Bridging the cracks on the board solved the problem.

Bruce

Top



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.