Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Positioning Floorstanding Speakers

Our Newest Flagship Model: The M100

Why We Make Our Own Drivers

Wall'O'Fame
"Serenity Cinema", now with 40% extra Serenity!
Updated as requested.
Who's Online
3 registered (frozen, Ajax, MarkSJohnson), 126 Guests and 8 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
12658 Members
11 Forums
22680 Topics
400368 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17695
pmbuko 16221
SirQuack 13309
CV 11054
MarkSJohnson 10668
Meanwhile On Facebook

8| Don't miss Andrew Welker's post on our message boards about the new subwoofer...

󾓲 The April Newsletter is out! Did you get your copy? http://www.axiomaudio.co...

Double-take! :O How well do you know our line? First one to spot the surprise...

Page 4 of 5 < 1 2 3 4 5 >
Topic Options
Rate This Topic
#358607 - 11/13/11 11:07 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: chesseroo]
fredk Offline
axiomite

Registered: 12/06/07
Posts: 6953
Loc: Canada
[quote=chesserooI don't think i do anything for 7 hours a day except sleep, and maybe work.
[/quote]
Not even... oh, right, your married.
_________________________
Fred

-------
Blujays1: Spending Fred's money one bottle at a time, no two... Oh crap!

Top
#358612 - 11/13/11 11:49 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: fredk]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1806
My EP-600 doesn't have an amp in it at the moment.. and i am debating whether or not to get another amp for it.. it is past its 5 year warrantee period. However, with that said, the amp had about 1,500 hours on it when it died... Not much at all for a period of 5 years of use... The way i know the hours is the Sub has the same number of hours that my projector bulb has....

I have to decide if i want to spend 600$ on a new amp for the EP-600, or move on to another company as well... Right now i am using 2 JBL 8" subs that are about 12 years old and have thousands of hours on them.... Granted they have no where near as much punch as the empty 600 that is still sitting in the room use to have though..

I have also though about buying a plate amp for the 600, and "getting that to work" I don't know what the failure rate of these amps actually are, but there are and have been a number of problems reported on the forums. However, i would imagine this is a small percentage of the total quantity produced... But with that said... it DOES suck to be the one with an EP-600 with no amp in it, my amp died about 4 or so months ago....

Originally Posted By: Robert_W

2 - HSU ULS-15's on the way.


Having just looked these up.. on Sale for 1,100$ each.. thats only about 400$ more than the amp for the EEP-600 (i was considering running 2 600's) i think this is what i will go with. I will find a plate amp and get the EP-600 "working" again at later date and have that for a secondary system...


Edited by dakkon (11/13/11 11:55 PM)

Top
#358627 - 11/14/11 08:09 AM Re: EP - 600 Dead. Again. 6th amp needed. [Re: SBrown]
Murph Offline
axiomite

Registered: 10/05/06
Posts: 6614
Loc: PEI, Canada
Originally Posted By: SBrown
Donating your M80's!! I wouldn't let anyone touch my babies,let alone give them away. What version of the speakers and sub do you have...


I can understand it. I did just that with my old Harmon Kardon speakers and about 30' of leftover speaker wire from before my Axioms. A Boys and Girls Club close by was building a HT/gaming room in the basement.

I was really impressed with how how were setting it up for use. The kids had to earn HT room credits by participating in physical activities. Kids with disabilities that prevented the more physical fun, earned points by participating in more social type games and activities.

The kids didn't have to go out of their way to earn these points as this was all stuff they were probably doing before there was a choice. Just now, they couldn't shirk away from the previous physical stuff completely to spend all their time in the HT/game room.

My donation wasn't nearly as extravagant as M80s but I liked knowing they were appreciated instead of gathering dust in my closet.
_________________________
With great power comes Awesome irresponsibility.

Top
#373429 - 04/15/12 10:00 AM Re: EP - 600 Dead. Again. 6th amp needed. [Re: Brent]
audiovue Offline
newbie

Registered: 01/05/06
Posts: 4
Loc: Québec/Canada
Hi,
I have the same problem. With m'y ep 600 amp v.2 and i am enjoy with Axiom after warrantie service.
Brent accepting replace my v2 amp for brand new v.3 amp.
It is normal with électronics having some probs And i am consider i am on l'y ont Lucky...

And if you sent back the sub probably résolve yourte problems

Regards
Robert Lussier

Top
#373446 - 04/15/12 02:15 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: Robert_W]
Gary Vose Sr Offline
devotee

Registered: 03/17/12
Posts: 302
Loc: Casa Grande, AZ
I've reread this thread today, as I did read it originally when it was first started. Tough call I think, as this wasn't an on going issue with 600's owners. If it had been, then Axiom would had to have treated this matter like the auto industry, as part of a recall, I would think.

Earlier in my life I worked as a Industrial maintenance mechanic for thirteen years. Dealing in mechanical, electrical, and sometime electronic diagnostics and repairs. It seems to me that the mathematical probability that each of these five amp being defective, and being the sole cause are astronomical to say the least.

My training then tell me there is something else in play here about this particular unit, which leads to the amp failure.
If this was my situation, I would have asked for a replacement unit.

Axiom is well known for it's research & development, normally this means forward looking going out. But sometimes one must take a step backwards, to look at what has already been researched & developed. Now again I stated earlier I thought it was a tough call, because it was an isolated situation. Axiom was certainly not obligated in anyway in having to take back and exchange this unit. But I would have still asked, especially knowing that I've made numerous purchases from Axiom in the past.

Who knows, if asked, Axiom may had gladly taken it back to try and find an under lying problem with this unit. They could have possible resold it as refurbished (not taking a total hit) and making a totally satisfied customer as well. Making customers happy is what Axiom is well known for.

These are just my thoughts, I don't fault anyone on the handling of this particular matter. The OP as he has stated, has moved on, did a very nice deed in donating his Axiom gear locally. I hope he's enjoying his new HT equipment as well.
_________________________
"When arguing with an IDIOT... make sure the person you're talking to... isn't doing the same."

Top
#373455 - 04/15/12 04:31 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: Robert_W]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1806
Gary, when my amp on my orignal version 600 failed, Andrew tested it on the work bench.. The main board had died... The first version of the amp was a 1 channel 600W amp... the new amps are 2 mono channel 300W amps...

As you know i wound up getting a new amp for my old 600... the new amp has a 5 year warrantee..


The op's problem could have possibly been something within his house, maybe in adequate wiring or low voltage.. Since as voltage drops current has to increase to maintain the same amount of power....

No telling....

Top
#373459 - 04/15/12 05:15 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: dakkon]
SBrown Offline
aficionado

Registered: 11/16/10
Posts: 804
Loc: Victoria,BC
Originally Posted By: dakkon
Gary, when my amp on my orignal version 600 failed, Andrew tested it on the work bench.. The main board had died... The first version of the amp was a 1 channel 600W amp... the new amps are 2 mono channel 300W amps...

As you know i wound up getting a new amp for my old 600... the new amp has a 5 year warrantee..


The op's problem could have possibly been something within his house, maybe in adequate wiring or low voltage.. Since as voltage drops current has to increase to maintain the same amount of power....




No telling....


Now you see my power cable asphyxiation! sweet.


Edited by SBrown (04/15/12 05:16 PM)
_________________________
Beauty is in the eye of the beer holder.

Top
#373461 - 04/15/12 05:52 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: SBrown]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1806
Originally Posted By: SBrown

Now you see my power cable asphyxiation! sweet.



wink It wouldn't be as much entertaining around here without some harassment :~)

Top
#373465 - 04/15/12 06:30 PM Re: EP - 600 Dead. Again. 6th amp needed. [Re: Robert_W]
Gary Vose Sr Offline
devotee

Registered: 03/17/12
Posts: 302
Loc: Casa Grande, AZ
Originally Posted By: Robert_W


I've tried everything that I can think of to get it to work and or figure out why it's dying.

I have multiple dedicated 20 and 30 amp circuits to my audio / video area. All of it on good quality protection. New home with good wiring. I've tried hooking it up to different ones.


I have 3 other subs in my home including the EP-350. Every other one of them works fine when I hook them up to the same cable that runs the EP-600.

My M&K MX-200 has been hooked up to the same system (Outlaw 990 pre amp) for the same amount of years playing exactly the same material and it just works. Period. Original amp. And it's 20 years old give or take a year or two.

dak, I agree, you are absolutely right, high current and electronics are certainly not made for each other, over time high current win that battle each and every time. The OP made some statements here though, which steered me in the direction I took. New home good wiring, quality protection, he also did some trouble shooting as well.

These days with all the electronics one might have in a home(appliances,computers,office equipment,TV's,auto equipment,garage door opener, etc)if there was a voltage problem he would know, as a pattern would had developed.

I all agree with you, who knows what the problem was.




_________________________
"When arguing with an IDIOT... make sure the person you're talking to... isn't doing the same."

Top
#373480 - 04/16/12 01:09 AM Re: EP - 600 Dead. Again. 6th amp needed. [Re: Robert_W]
2x6spds Offline
connoisseur

Registered: 03/16/02
Posts: 2726
Loc: CA, USA
I have a Dahlquist PDQ 1500. It's been running every day for more than 10 years. I have a Velodyne CHT10. It has worked every day for 19 years, never let me down. I had a Kenwood SW300, 12" sub, worked fine until I cranked it with the Dreamworks version of HG Wells' The Time Machine. Blew little pieces of rubber all over the room. A spectacular demise actually though followed by a sad degrading series of farting noises.

These EP subs, just seem to expire frequently and without drama. What are the chances of an EP600 outliving its warranty? Someone must have run the numbers.
_________________________
Enjoy the Music. Trust your ears. Laugh at Folks Who Claim to Know it All.

Top
Page 4 of 5 < 1 2 3 4 5 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.