Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Positioning Floorstanding Speakers

Wall'O'Fame
Greetings fellow Axiom owners...
HG Rosewoods Part 3
Who's Online
4 registered (Boltron, SBrown, michael_d, oakvillematt), 114 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13294 Members
11 Forums
22822 Topics
403174 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17739
pmbuko 16257
SirQuack 13318
CV 11136
MarkSJohnson 10829
Meanwhile On Facebook

Hope everyone's got their summer favourite playlists cued up for the weekend! W...

(y) Love this customer review of the M2s! "the first time listening to my new a...

These LFR1100 speakers in custom Eggshell White are on their way to Taiwan (yes,...

Friday the 13th . . . oooooh! Who's your favorite Slasher flick character?

Page 2 of 8 < 1 2 3 4 5 6 7 8 >
Topic Options
Rate This Topic
#131540 - 03/12/06 10:07 PM Re: ep500 no power
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
Best bet is to e-mail or call Axiom, the fuse should not be hard to replace, just remember to switch voltage to 220.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#131541 - 03/12/06 10:08 PM Re: ep500 no power
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6720
Loc: The Peoples Republic of Il.

It should tell you on the back of the amp as to what type of fuse it will take.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#131542 - 03/12/06 10:09 PM Re: ep500 no power
Tharkun Offline
connoisseur

Registered: 01/05/05
Posts: 1039
Loc: Tracy, California
Right above the fuse block you removed, you should see it states to use a 3.15A 250V Slow-Blow Fuse.
_________________________
ROCK 'N' HAXIOM Theater

Top
#131543 - 03/12/06 10:10 PM Re: ep500 no power
mikec Offline
old hand

Registered: 01/16/06
Posts: 72
i sure hope this type of fuse is available everywhere (meaning: Philippines)

it says T3.15AH 250V

this sucks. i waited 2 months for this.

Top
#131544 - 03/12/06 10:12 PM Re: ep500 no power
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6720
Loc: The Peoples Republic of Il.

I doubt it should be hard to find.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#131545 - 03/12/06 10:44 PM Re: ep500 no power
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
If you can't find the fuse I bet Axiom can get you one quick.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#131546 - 03/13/06 12:08 AM Re: ep500 no power
mikec Offline
old hand

Registered: 01/16/06
Posts: 72
thanks guys. i've sent someone to buy one for me ... will keep you guys updated. (actually, Ill be back if it doesnt work ... i wont be if it works, because id be busy listening)

Top
#131547 - 03/13/06 12:19 AM Re: ep500 no power
HomeDad Offline
connoisseur

Registered: 12/29/05
Posts: 3301
Loc: Central,California
Once you get it working, let us know what you think. Happy listening.
_________________________
A computer once beat me at chess, but it was no match for me at kick boxing.

Top
#131548 - 03/13/06 12:39 AM Re: ep500 no power
mikec Offline
old hand

Registered: 01/16/06
Posts: 72
i put in the fuse. it popped too. it doesnt have the same FAT string in the middle of the fuse

Top
#131549 - 03/13/06 01:05 AM Re: ep500 no power
mikec Offline
old hand

Registered: 01/16/06
Posts: 72
i replaced both fuses ... and they both popped.
I returned one of the original unpopped fuse ... and put in a new one (switched it back to 110v) then plugged it in using 110v transformer. i got the amber light which changed to a yellow light. i dont know what a yellow or green light is on this unit because i've never seen both)

Top
Page 2 of 8 < 1 2 3 4 5 6 7 8 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.