Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Speaker Placement: Unusual Room Layouts and Elevating Speakers

Wall'O'Fame
Greetings fellow Axiom owners...
HG Rosewoods Part 3
Who's Online
5 registered (JohnK, Ajax, CV, evaredy, Ken.C), 56 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13313 Members
11 Forums
22855 Topics
403811 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17754
pmbuko 16268
SirQuack 13325
CV 11171
MarkSJohnson 10856
Meanwhile On Facebook

Hurry - sale ends Sunday!

Get a Gift Card Worth 20% of Your Purchase! Save hundreds!

Got your new In-Ceiling speakers yet? #atmosready http://axiomaudio.com/m3-in-c...

(y) Can't wait for the next evolution of surround sound to go mainstream!

Page 4 of 14 < 1 2 3 4 5 6 ... 13 14 >
Topic Options
Rate This Topic
#330964 - 12/09/10 10:27 PM Re: EP500 Not working [Re: MarkSJohnson]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Originally Posted By: MarkSJohnson
Originally Posted By: Dduval
not my Wife's big rubber ***K!

TMI, Dana, TMI.

If she can't get it to work right, give it to the dog as a chew toy just before hosting a Holiday party with your friends, neighbors and employers.

That might cure the curse. It's worth a try.

Oh, and post video at YouTube to increase your chances of successful exorcism.


Mark,

If she does get it to work properly and at the proper RPM's, should I still post a video? laugh

Dana
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#330968 - 12/09/10 10:33 PM Re: EP500 Not working [Re: Dduval]
BobKay Offline
connoisseur

Registered: 03/23/10
Posts: 3131
Loc: Massachusetts Badlands
No. We wanna see the video of TRYING to get it to work. One never gets to see porn out-takes.
_________________________
"Ya rolls the dice and ya takes yer chanskes."
Popeye

Top
#330976 - 12/09/10 10:58 PM Re: EP500 Not working [Re: BobKay]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Originally Posted By: BobKay
No. We wanna see the video of TRYING to get it to work. One never gets to see porn out-takes.


I asked Mark, get your own big rubber "duck" grin
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#331005 - 12/10/10 10:04 AM Re: EP500 Not working [Re: Dduval]
Da_Gimp_Pimp Offline
connoisseur

Registered: 06/23/07
Posts: 4017
Loc: Sitting down somewhere
Originally Posted By: Dduval
Originally Posted By: BobKay
No. We wanna see the video of TRYING to get it to work. One never gets to see porn out-takes.


I asked Mark, get your own big rubber "duck" grin


Don't ask for the video wink smile .
_________________________
Does a dyslexic atheist not believe in dog?

Top
#331034 - 12/10/10 11:58 AM Re: EP500 Not working [Re: Da_Gimp_Pimp]
BobKay Offline
connoisseur

Registered: 03/23/10
Posts: 3131
Loc: Massachusetts Badlands
Too late. Already slithered into the hands of Julian Assange. Watched it this morning (@3:00)Really, a quart of extra virgin olive oil? I mean, I see the allusion, but the cheap stuff woulda worked fine.
_________________________
"Ya rolls the dice and ya takes yer chanskes."
Popeye

Top
#331081 - 12/10/10 02:46 PM Re: EP500 Not working [Re: BobKay]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Olive oil? Looks like bodily fluids to me...

http://www.youtube.com/watch?v=s7t651gjjrA


smile
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#331135 - 12/10/10 06:05 PM Re: EP500 Not working [Re: Dduval]
BobKay Offline
connoisseur

Registered: 03/23/10
Posts: 3131
Loc: Massachusetts Badlands
Originally Posted By: Dduval
Olive oil? Looks like bodily fluids to me...

http://www.youtube.com/watch?v=s7t651gjjrA


smile


You are digusting, therefore, I hope you stick around here for a long time. We were just about to place an ad on Monster.com, but we don't need to now. Awesome!
_________________________
"Ya rolls the dice and ya takes yer chanskes."
Popeye

Top
#331502 - 12/14/10 12:54 PM Re: EP500 Not working [Re: BobKay]
Dduval Offline
devotee

Registered: 01/14/09
Posts: 349
Just got my new replacement EP500 amp. The new amp has cooling vents on the back. Like this

My old V2 amp does not, is this the only difference? I'm assuming this is the newer V3 amp?

Dana
_________________________
M80's, QS8's, M22's, CHT SHO-10, Dual CHT SS-18.1's, Onkyo NR3008, Mitsubishi WD-73740

Top
#331504 - 12/14/10 01:00 PM Re: EP500 Not working [Re: Dduval]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13325
Loc: Iowa
That appears to be the newer amp they started sending out mid year, newly designed, and does not have the flaws of some of the previous models. That is why Axiom hired Andrew.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#331558 - 12/14/10 04:26 PM Re: EP500 Not working [Re: SirQuack]
icehawk21 Offline
old hand

Registered: 04/23/06
Posts: 93
Where's the RCA input/output? Do they use an RCA to XLR adapter instead?

Just wondering because I <???may???> purchase a second EP500 and my new receiver only has RCA outs for the two subwoofer outputs.

Top
Page 4 of 14 < 1 2 3 4 5 6 ... 13 14 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.