Get Free, Friendly, Expert Advice
Call 1-866-244-8796 or email

Designed and Manufactured in Canada Since 1980


AxiomAudio Blog

Sneak Peek into Axiom’s Current Research and Development

Axiom’s Newest Speaker: The In-Ceiling M3

Outdoor Speaker Placement

Wall'O'Fame
Experimental Atmos
Greetings fellow Axiom owners...
Who's Online
4 registered (BBIBH, a401classic, Ken.C, medic8r), 67 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Financing
Forum Stats
13322 Members
11 Forums
22895 Topics
404590 Posts

Max Online: 378 @ 02/24/13 04:33 PM
Top Posters
Ken.C 17781
pmbuko 16277
SirQuack 13336
CV 11208
MarkSJohnson 10899
Meanwhile On Facebook

󾓶 The first review of the LFR880s is out! "If you are adding or upgrading stere...

So much going on in this month's newsletter - new product announcements, a new v...

Love this comment from Doug T! "The M22 bookshelf speakers sound so clean and a...

󾓶 Andrew has spoken! Big update on the AxiomPlay Wireless Platform on the Axiom...

Page 1 of 7 1 2 3 4 5 6 7 >
Topic Options
Rate This Topic
#347957 - 05/11/11 10:52 PM EP500 will not power up
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
My EP500 quit working tonight. It will not power up. Is there a fuse inside that could have blown? Could not find anything using the search on the forum.

Top
#347962 - 05/11/11 11:10 PM Re: EP500 will not power up [Re: stevej]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13336
Loc: Iowa
First have you tried unplugging it from the wall outlet for 5 min or so, then plugging it back in? If that does not work, I do believe there is a fuse that can be replaced on the back.
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#347963 - 05/11/11 11:12 PM Re: EP500 will not power up [Re: SirQuack]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
I tried that. I assume the back has to be removed to get to any fuses. Can't find any fuse holders on the back.

Top
#347964 - 05/11/11 11:19 PM Re: EP500 will not power up [Re: stevej]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13336
Loc: Iowa
Zak's thread a few down from yours has these pics, I assume you have the newer amp design on the left? The older design had slow blow fuses which could be removed. The Axiom techs go home at 11pm eastern, so you might have to call them tomorrow..


_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#347966 - 05/11/11 11:27 PM Re: EP500 will not power up [Re: SirQuack]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Mine looks more like the one on the right. But does not have what looks like 3 fuse holders just above and to the left of the power switch. I tried calling Axiom around 10 but no one was available. Will try tomorrow. Need to get to bed now. Will post tomorrow if I get it resolved.
Thanks

Top
#347967 - 05/11/11 11:31 PM Re: EP500 will not power up [Re: stevej]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13336
Loc: Iowa
Hope you get it figured out Steve...Randy
_________________________
M80s-VP180-QS8s-EP600-2xEP350 Denon3808 Outlaw7700
M22-OWM22-VP100-Denon2805
Audio Nirvana

Top
#347968 - 05/11/11 11:32 PM Re: EP500 will not power up [Re: SirQuack]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Thanks. Will post the result as soon as I talk to someone tomorrow.

Top
#347969 - 05/12/11 01:55 AM Re: EP500 will not power up [Re: stevej]
dakkon Offline
connoisseur

Registered: 02/08/04
Posts: 1846
if your amp is a version one like mine, the fuses are below the power switch, right below where the power cord plugs in. there are 2 3amp slow blow fuses in a small cartridge, you will need a flat head or something of the sort to pop the cartridge out. if you look very closely at the photo of the amp on the right, you can see a black box looking area below the power plugs, that is the area i am referring to..

JC had to tell me where the fuses were for my amp, i had no clue either....

Top
#348020 - 05/12/11 07:20 PM Re: EP500 will not power up [Re: dakkon]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
dakkon Thanks for the info. Just got home and checked it. Would not have known to look there. The fuse is blown. Also talked to Brent. He said it does happen once in a while. So need to go get one. Thanks for the replies everyone. Sirquack I should be up and running later tonight. Have to head in to town and find the fuse.

Top
#348024 - 05/12/11 08:52 PM Re: EP500 will not power up [Re: stevej]
stevej Offline
old hand

Registered: 08/08/09
Posts: 76
Well I put a new fuse in and it will power up now but no sound. And when I first turned it on it was humming pretty loud and make a crackling sound. No sound from the sub. So I called and talked to Brent again and he had me send a pic of the amp so he can see which one it is. He will get back with me tomorrow. Will let you all know what the verdict is. It is really great to have someone this late in the evening that will help you out. Thanks Brent and Axiom. You will not find many companies that would have tech support as late as 11:00pm.

Top
Page 1 of 7 1 2 3 4 5 6 7 >



Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Home  |  Corporate Info  |  Products  |  Message Board  |  FAQs  |  Warranty  |  Site Map  |  Privacy Statement   |  Contact Us

©2014 Colquhoun Audio Laboratories Limited
All Rights Reserved.