You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » ep125 help

Topic Options
Rate This Topic
#151006 - 11/08/06 10:01 PM ep125 help
patrickwhite Offline
newbie

Registered: 11/08/06
Posts: 1
This is a bit of a technical question...

I have a axipm ep125 (i believe the first edition), and it has recently stopped working. It just doesn't seem to get any power (the led doesn't turn on). I believe it was due to an electrical spike. The fuse was burnt and I couldn't find any 1.25 A fuses. I chose a 1 A fuse instead and the speaker still doesn't power on.

Is there any reason that the subwoofer wouldn't turn on with an under-rated fuse?

Also, Is there any specific part i should look at if I want to repair something that was fried inside it (i'm confident if i have a bit of guidance, i am an electrical engineer)

Thanks if you can help.

Top
#151007 - 11/08/06 11:59 PM Re: ep125 help [Re: patrickwhite]
bridgman Offline
axiomite

Registered: 08/25/04
Posts: 6052
Loc: Bowmanville, Ontario, Canada
Unless the 1A replacement fuse blew I don't think an under-rated fuse should stop the sub from turning on. The new fuse might blow in normal use but that's not your problem right now.

We haven't seen a lot of Axiom subwoofer problems here other than those related to shipping damage or teething problems with the first EP500/600 units a couple of years ago so there may not be a big body of experience re: what components to look at. I assume you checked to make sure that the new fuse didn't fry, and that it's not a slow-blo vs. an original fast-blo ?

Axiom's customer service is really good so first step might be to give them a call.
_________________________
M60ti/VP180/QS8, SVS PC-Plus 20-39, EP500
M5HP, Sierra-1, M40ti
M2ti, M3v4, VP100

Top
#151008 - 11/09/06 12:01 AM Re: ep125 help [Re: patrickwhite]
BrenR Offline
connoisseur

Registered: 12/10/03
Posts: 3602
Loc: Winnipeg MB Canada
First off, I'd give Axiom a call... they may really go above and beyond with helping you before you start having to tinker at all yourself.

And no... the only problems you should encounter with using an underrated fuse would be it blowing prematurely (insert joke here, Peter!) or if the original fuse was a fast-blow (insert joke here, Peter) type and you used a slow-blow (and here) type. It may not have opened the circuit fast enough to protect from damage.

Bren R.

Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,224 Registered Members
15 Forums
23,992 Topics
424,049 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13567
CV 11677
MarkSJohnson 11437
2 registered (Kevin1, norap)
85 Guests and
2 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup