You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » EP 500 popping and burnt smell, but still working

Page 1 of 3 1 2 3 >
Topic Options
Rate This Topic
#328335 - 11/13/10 04:37 AM EP 500 popping and burnt smell, but still working
Randy_Perkins Offline
veteran

Registered: 08/31/06
Posts: 193
Loc: Franklin Indiana
Hey guys
long time no see. anyway

I'm sitting here on my couch. Not even playing my surround sound system. I hear a couple popping sounds and can smell something burning over by my EP500. I also have a cheap lamp over there, but I dont think that was it. freaked me out. I checked the cords behind the lamps and they were fine.

The EP500 still plays fine. The smell went away. I'm wondering if there has been any issues with capacitors blowing in these units ? I'm thinking my EP500 is 3-4 years old. Still under warranty smile I really dont abuse my axiom/denon system, its quality over quantity of sound for me.

The only issue I have had is a ground loop thru the sub. I moved here 1.5 years ago and it started after that. I traced it down to the incoming cable tv line. I tried an isolation filter on the cable line (Basically a capacitor ), but then the signal level on the cable was poor. The cable tv service rep was wortheless, said his power was clean. I eventually removed the chassis ground screw on the EP500, as outlined in the manual. This reduced the hum by 95% which was pretty good.

I dont know what to do now. I wanna take apart the sub to inspect the electronics, but dont want to void my warranty. Maybe it was the lamp, I did just change the bulb in it today. the bulb is still good.

Anyone else have an experience like this ?

Thanks
Randy Perkins


Edited by Randy_Perkins (11/13/10 04:42 AM)
_________________________
Axiom M22,Ep500,Qs8,VP150, Denon 2807,1940, Sangean HDT-1X

Top
#328339 - 11/13/10 07:02 AM Re: EP 500 popping and burnt smell, but still working [Re: Randy_Perkins]
RickF Offline
axiomite

Registered: 02/26/05
Posts: 5210
Loc: Vero Beach, Florida
I think 90% of the time ground loops can be traced back to the incoming TV source outside of the building and it seems to me like most everybody spends all of their time indoors looking for these loops. Randy if I were in your shoes I'd take anything the chucklehead CATV installer said with a grain of salt and go outside to the incoming CATV source and physically inspect each and every grounding block, nut, bolt and wire with a tug of pliers or a tap with a hammer. I'm betting you'll find a connection loose, corroded or not connected properly.

If you do that and properly connect the wires using the CATV grounding diagram linked below I can pretty much guarantee you that you'll solve your grounding issue, until the chuckleheaded satellite installer installs the satellite dish.

CATV Ground Diagram

Regarding the sub, put it through it's paces and if something's not right I'd certainly give Axiom a shout.
_________________________
Rick
Our Room

smile

Top
#328353 - 11/13/10 10:58 AM Re: EP 500 popping and burnt smell, but still working [Re: RickF]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4870
Loc: Tulsa, Oklahoma
I had a ground loop hum that was caused by my cable TV. I purchased a ground islolator from axiom... I even convinced my cable company to pay for it, but it took a little persuasion!
_________________________
-David

Top
#328380 - 11/13/10 02:46 PM Re: EP 500 popping and burnt smell, but still working [Re: terzaghi]
Randy_Perkins Offline
veteran

Registered: 08/31/06
Posts: 193
Loc: Franklin Indiana
Thanks for the replies. I called Axiom but their machine said they couldn't find anyone right now. They probably got the stereo up too loud smile

I did a little sniffin' around. If I put my nose right by the EP500's electronics I still get a faint smell. The sub's still working. The green light is on. I put on some I aint your repo man ( though This is the Ray Lamontagne song that's sustaining me right now), and smelled the air coming out the port in front. No smell. So then I thought maybe the electronics are sealed. sure enough . My thoughts are that it aint the voice coils. I'm just gonna wait for them to call me back.

Since I aint posted for awhile I took some pics of my setup . I'm quite pleased with the stereo separation and the height of the rears.

As far as the ground loop. I live in a single story patio/garden type apartment complex. There's 4 appts under my common roof. each appt has 2 cable connections coming from outside. I'm not gonna mess with it outside. I canceled the tv part of my cable when I got laid off. However, since they are going to all digital with a DTA , they must not feel compelled to put on filters. I got a nice setup with mythtv/haupauge 950q/scte65scan. We're gonna let that dog sleep. I mainly mentioned the ground loop with regards to my EP500 issue.

anyone had any EP500 issues like this, specifically after the infant mortality period has passed ?


Edited by Randy_Perkins (11/13/10 02:58 PM)
_________________________
Axiom M22,Ep500,Qs8,VP150, Denon 2807,1940, Sangean HDT-1X

Top
#328386 - 11/13/10 05:12 PM Re: EP 500 popping and burnt smell, but still working [Re: Randy_Perkins]
Adrian Offline
axiomite

Registered: 12/27/08
Posts: 6875
Loc: It's all about the location.
As Rick mentioned, it would be best to talk with an Axiom representative re the sub/amp.

Nice setup you have, Randy, very clean looking....oh! and your parakeet's a handsome little fellow too.
_________________________
Half of communication is listening. You can't listen with your mouth.

Top
#328392 - 11/13/10 05:40 PM Re: EP 500 popping and burnt smell, but still working [Re: Adrian]
Randy_Perkins Offline
veteran

Registered: 08/31/06
Posts: 193
Loc: Franklin Indiana
Thanks for the compliments. My bird's name is hercules. I got him offa craigslist, so he already had a name. He can be a little demanding and has a loud squawk, but keeps me company. He's real friendly when I am eating :0

I got a call back from J.C at Axiom. After describing issue he verified my warranty and asked for me to send him a pic of the back my sub. I'm guessing they got a couple rev's of the amp. An email is forthcoming with further directions. It looks like I am getting a replacement amp.

He didnt go into details as to what he thought happened. I'm lucky I was sitting here when it happened. The popping wasn't real loud nor the smell overpowering. If I was in the other room I would have missed it altogether. I never would have known a gremlin was at work inside my sub's amp as the sub is still working. I havent tried to adjust the crossover/gain/other settings to see if anything went out since I still got some bass right now.

Its funny I dont even get upgradeitus anymore. But I would like to have another set of M22 to put in my bedroom. Does that count ? That way I wouldnt have to play the game " guess the name of this song by the bass line" when I am in the shower.

Randy
_________________________
Axiom M22,Ep500,Qs8,VP150, Denon 2807,1940, Sangean HDT-1X

Top
#328394 - 11/13/10 05:51 PM Re: EP 500 popping and burnt smell, but still working [Re: Randy_Perkins]
Adrian Offline
axiomite

Registered: 12/27/08
Posts: 6875
Loc: It's all about the location.
Well, technically buying a new pair of M22's is in fact an upgrade since Axiom has recently released V3!!
_________________________
Half of communication is listening. You can't listen with your mouth.

Top
#328416 - 11/13/10 10:38 PM Re: EP 500 popping and burnt smell, but still working [Re: Adrian]
Randy_Perkins Offline
veteran

Registered: 08/31/06
Posts: 193
Loc: Franklin Indiana
Originally Posted By: Adrian
Well, technically buying a new pair of M22's is in fact an upgrade since Axiom has recently released V3!!


Ha . thats a good one. I have the M22ti so i'm a couple generations behind. I had to search to find the suffix of my speakers. I was thinking it was SE but it is TI. Then I noticed over at http://www.axiomaudio.com/m22.html , the professional reviews, the reviews are of the TI series. hmm
make note to self to locate used pair of TI so all are matching.

got me wondering what version of EP500 I have. V2 is what I have. noticed the back panels are different. Main diff I notice is new ones dont have trim, can't bypass crossover. but have picked up, subsonic filter, and triggers. I imagine you guys have already went thru all these points. Oh and the power consumption is higher in the newer ones, with a larger fuse. This is all by just glancing at the back panels, so take it with a grain of salt. Personally I hope I get the same thing back I am sending in. I wouldnt miss the trim, but I like to be able to disable the crossover and and utilize the crossover in the head unit. subsonic filter? - well i guess it is at 20 hz. My EP500 is a near-subsonic-accentuator smile Oh and just read about setting the crossover on the newer models. It say set at or just above the freq of crossover in head unit. I imagine then you would have one slope going to your mains, and a greater slope going to your sub?? The greater power requirements got me thinking . Does the EP500 have a dig amp (class D) . Does the V2 have one but the V8( err V3 ) have AB with DSP. I really oughta do the research before I ask about this. basically just thinking out loud. however

I'd like to get a pdf of the user manual for my V2 EP500 and for the M22ti. anyone know how I can get the old versions. I dont have the hard copies anymore ?

And JC called back . Axiom set up a prepaid ups label for me to return the defective amp. $30 isnt bad considering the weight. Glad they got away from DHL or whomever it was back in 2007. Couple of my boxes were torn up, but the insides were golden. He didnt have any opinions on what may have went wrong with my unit. I'd like to see what burned up but notice a funky allen head bolt. so I surmise they dont want you in there poking around. I'll flip the knobs around to see what gives before sending it back. might even break out my audiocontrol sa-305x analyzer. I can never remember X. I think its 0 or 2.
http://www.audiocontrol.com/t35/16466/19894/Acoustic-Analyzers/Audio-Analyzer-SA--3052.html
Had a new one of these in mid 90's. sold it for a different lifestyle. bought a used one last year off ebay. works but has it quirks. need to send it back to AC to get it gone over.

well let me browse around now, curious bout the V2/3 of ep500.
plus I've rambled enough


Darn
now I see there is a VP180 center channel. thats sweet . I hereby revoke my lack of upgradeitis.


Edited by Randy_Perkins (11/13/10 10:47 PM)
_________________________
Axiom M22,Ep500,Qs8,VP150, Denon 2807,1940, Sangean HDT-1X

Top
#328424 - 11/13/10 11:34 PM Re: EP 500 popping and burnt smell, but still working [Re: Randy_Perkins]
JohnK Offline
shareholder in the making

Registered: 05/11/02
Posts: 10621
Randy, all the EP500s have class D amps which operate by switching on and off several hundred thousand times a second, but there's nothing digital about the basic operation. "D" is simply the amplifier class that follows C.

There's no internal crossover, just a variable low pass filter. It can essentially be bypassed from interfering with the lower frequency crossover which a receiver does if the filter is set at the 150Hz max.

My diagnosis is that you'll remain upgradeitis-free if you just buy new M22s for another setup, not to replace the current ones.
_________________________
-----------------------------------

Enjoy the music, not the equipment.



Top
#328427 - 11/14/10 12:17 AM Re: EP 500 popping and burnt smell, but still working [Re: JohnK]
Randy_Perkins Offline
veteran

Registered: 08/31/06
Posts: 193
Loc: Franklin Indiana
Originally Posted By: JohnK

There's no internal crossover, just a variable low pass filter. It can essentially be bypassed from interfering with the lower frequency crossover which a receiver does if the filter is set at the 150Hz max.


Thanks for the reply. I've been looking over some threads and it appears that when I set my crossover ( err. var lp filter ) at bypass it is really at 150hz. I'd have to look at what my crossover at the denon is set at, and get the DB per octave (# of poles) of the denon and the sub amp's crossover ( err variable filter ) to see if technically 150hz crossover is the same as bypass. I imagine it's not but my ears cant hear the difference.

i just read a 52 page thread about v2/v3 that reminded me of 52 channels and nothing on . I almost posted this on there, but didnt want to bring it back to life. you can thank me later smile

but if you know of a post that details the difference in amplifier, difference in input power required for the same output, and freq response of ep500 v2/v3 , I'd like to see it.

I gotta chuckle out of "class D amps which operate by switching on and off several hundred thousand times a second, but there's nothing digital about the basic operation". smile smile thanks

can you point me to where it lists which axiom sub amps are class D ?

and to me dsp is not class D amplification. the "digital signal processing " would definitely have a A-D conversion, then some processing, then optionally a D-A conversion depending on the class of amplification ( D or AB ). Of course my thinking could be off again, it happens regularly. I'm open to suggestions to bring it back on course

Randy

ps you're right about the upgradeites. I think V3 would be fine, or even v2 if the price was right.

pss. i saw where the upgrade program was degraded. I can understand from Axioms point. I'm grateful I was able to utilize it when I did. I couldnt of upgraded without it.

psss I stand corrected as
wikipedia says " The term "class D" is sometimes misunderstood as meaning a "digital" amplifier. "


Edited by Randy_Perkins (11/14/10 12:24 AM)
Edit Reason: ps pss psss
_________________________
Axiom M22,Ep500,Qs8,VP150, Denon 2807,1940, Sangean HDT-1X

Top
Page 1 of 3 1 2 3 >

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,224 Registered Members
15 Forums
23,998 Topics
424,075 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13567
CV 11677
MarkSJohnson 11437
1 registered (jmone)
203 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup