You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » My EP600v2 Subwoofer amplifier died! :-(

Topic Options
Rate This Topic
#416855 - 02/04/16 01:54 AM My EP600v2 Subwoofer amplifier died! :-(
Richie Offline
veteran

Registered: 01/06/06
Posts: 139
Loc: IL, USA
I bought the EP600v2 subwoofer in December 2005, and this is actually the second amplifier inside it to die. The first one was replaced under warranty. I assume I will have to pay for this one! I would like to keep my EP600v2. I like the sound. Is it still fixable/repairable? Any help from Axiom tech support would be appreciated.
_________________________
4 M80s/VP150/EP600/Denon AVR-5308 & DVD-2910/
2 QSC SRA3622(1100wattsX2)/Carvin 1800HD(600wattsX2)

Top
#416857 - 02/04/16 02:32 AM Re: My EP600v2 Subwoofer amplifier died! :-( [Re: Richie]
a401classic Offline
connoisseur

Registered: 11/29/06
Posts: 1332
Loc: Alpharetta, GA
I'd call or email them directly - this is primarily an equipment owner-frequented forum that is usually not followed by Axiom employees.
_________________________
Scott

My HT

Top
#417762 - 03/15/16 10:15 PM Re: My EP600v2 Subwoofer amplifier died! :-( [Re: Richie]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13579
Loc: Iowa
I would call Axiom and see what they can do to help. The original designed amp is no more, parts are pretty much a no go. I had to get a new amp for mine about 3-4 years ago and it was a totally newer amp. I would see what they can work out..
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800



Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,273 Registered Members
16 Forums
24,080 Topics
425,206 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13579
CV 11708
MarkSJohnson 11444
1 registered (Mojo)
199 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup