You are not logged in. [Log In]


Forums » AxiomAir Discussion » AxiomAir General Discussion » No sound till poweroff and restart

Topic Options
Rate This Topic
#432607 - 06/17/19 02:37 PM No sound till poweroff and restart
elsewhere Offline
enthusiast

Registered: 06/05/10
Posts: 32
Hi guys. I'm on Toasted Macedamia v 2.10.3 and my airplay connects fine the first time but if I stop my music and try to play again, it looks like it is playing but there is no sound. I have to completely poweroff and start in order to make a connection again. I've tried a reboot from the iphone app and that does not help. only a complete power off and start.

Anyone else seeing this issue and know of a fix?

Top
#432638 - 06/19/19 12:37 AM Re: No sound till poweroff and restart [Re: elsewhere]
Ian Offline
President
connoisseur

Registered: 03/13/01
Posts: 1320
Hi elsewhere,

Is this happening in iTunes? Can you check you have the latest version of iTunes. Apple released a lot of AirPlay patches recently.
_________________________
Ian Colquhoun
President & Chief Engineer

Top
#432646 - 06/19/19 11:59 AM Re: No sound till poweroff and restart [Re: Ian]
elsewhere Offline
enthusiast

Registered: 06/05/10
Posts: 32
No not itunes. It happens when I airplay Soundcloud or the live stream at https://www.wnyc.org

I've basically lived with this issue by powering off and starting up every day but it's starting to get annoying.

Top
#432647 - 06/19/19 12:00 PM Re: No sound till poweroff and restart [Re: elsewhere]
elsewhere Offline
enthusiast

Registered: 06/05/10
Posts: 32
I want to point out that this is happening with my iphone and it is on the latest iOS. I use my phone to connect to the Air.

Top
#432656 - 06/20/19 03:14 AM Re: No sound till poweroff and restart [Re: elsewhere]
Ian Offline
President
connoisseur

Registered: 03/13/01
Posts: 1320
I asked Guillaume, who heads up the programming of the AxiomAir, if he had any thoughts on this and here is his response:

"Yes. I have heard of it. It has to do with a recent change in the Airplay protocol implementation of iOS. It only seems to affect mobile devices. In theory, the workaround is to disconnect from Airplay, start playing the media, and then connect to Airplay with the media already playing. Once we are finished with the implementation of AirPlay2 this will likely just fix itself. In the meantime you shouldn't need to restart the Air to recover however. Just disconnect from Airplay. Play the media so that it plays on the phone, and then connect to Airplay again. If that doesn't work, let me know and we can try to see if its something else I haven't seen before."

Currently our top focus is the implementation of AirPlay2. I don't have an exact date for the release because Apple is still doing updates to both the documentation and the code for AirPlay2 implementation in our type of O/S. This said, we do have AirPlay2 running now, the remaining items to be able to release AirPlay2 in the AxiomAir are not major, but still important.
_________________________
Ian Colquhoun
President & Chief Engineer

Top
#432664 - 06/21/19 09:18 AM Re: No sound till poweroff and restart [Re: elsewhere]
elsewhere Offline
enthusiast

Registered: 06/05/10
Posts: 32
I tested this and Guaillaume's information is probably correct. There seems to be a time out involved where if I tried to connect with playing media too soon it won't play but if I give it at least 10 minutes then I can connect while playing something.

For now, I put in a bluetooth dongle and I am able to play through bluetooth, stop, and reconnect with no issue. I'd rather use airplay but this will work till you guys come out with your airplay2 implementation.

Thanks

Top

Moderator:  Andrew, Debbie, Ian, Jc 
Forum Stats

15,361 Registered Members
16 Forums
24,227 Topics
428,919 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13629
CV 11735
MarkSJohnson 11445
0 registered ()
286 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup