Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 3 1 2 3
My EP500 just died and I am in need of some advice
#283777 12/25/09 01:33 PM
Joined: Jul 2008
Posts: 10
F
fanon Offline OP
frequent flier
OP Offline
frequent flier
F
Joined: Jul 2008
Posts: 10
Hi There,

My EP500 just died under my hands after working without any problems whatsover since august 2008.
Here's what happened. I just swithed it off, disconnected the AV cord and shielded cable from my AV. Gentle turned the EP500 on it's side, and replaced the spikes with the rubber feet. I then connected all leads again and swithed it on. Big Silence... :-(
The green light is on and I can hear a very soft humming from the ac transformer I think. I have checked all the fuses - 6 in total - but no success, there all okay. If I switch the AC on and then off, I hear a very soft boem... but the EP500 simple refuses to output any sound (I made sure, it's not my AV, I ve got an old SW)
Before going into the hassle of shipping it back (I live in Belgium) I would like to know if there's anything else left which I could do myself. I was thinking in terms of opening the box and checking the wiring. What's the best way of opening the box - at the front (the driver) or at the back? In case of the letter which screws do I have to loosen. I do have a background in electronics. Would checking this myself void my warrantee?
I would be very grateful for advice as I am a bit stuck.
Thanks.

Re: My EP500 just died and I am in need of some advice
fanon #283779 12/25/09 01:40 PM
Joined: Aug 2007
Posts: 3,400
connoisseur
Offline
connoisseur
Joined: Aug 2007
Posts: 3,400
Most Axiom products (including the subwoofers) are built to allow the customers to execute repaires and installs to avoid shipping the whole boxes. It really sounds like a wire got loose in the shuffling.
Since this is the 25th, I don't know if they have someone working at customer service, but it is worth a try. They will tell you immediately about the warranty.


E = MC2 = ((2M80 + VP180 + 4QS8)/(EP800 + EP500))^(ADA1500 x D2v)
AxiomAir/6xM2/4xM22/2xVP150/2xM3
Re: My EP500 just died and I am in need of some advice
EFalardeau #283781 12/25/09 01:48 PM
Joined: Jun 2003
Posts: 6,832
W
Wid Offline
axiomite
Offline
axiomite
W
Joined: Jun 2003
Posts: 6,832

I agree, sounds like a wire has come loose.


Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud

Re: My EP500 just died and I am in need of some advice
Wid #283782 12/25/09 01:59 PM
Joined: Sep 2004
Posts: 11,450
shareholder in the making
Offline
shareholder in the making
Joined: Sep 2004
Posts: 11,450
I would try hooking up a disc player or MP3 player to it's inputs just to make sure....

I know you didn't post about making changes to anything else but the sub, but I'd check anyway since it only takes a moment.


::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::
Re: My EP500 just died and I am in need of some advice
MarkSJohnson #283783 12/25/09 02:14 PM
Joined: Jul 2008
Posts: 10
F
fanon Offline OP
frequent flier
OP Offline
frequent flier
F
Joined: Jul 2008
Posts: 10
Mark, I 've done so but it stays dead .... ths anyway

Apart from my warranty question - anybody has the wisdom on which side to open the EP500 box (for best check up) and with which screws ?

Re: My EP500 just died and I am in need of some advice
MarkSJohnson #283784 12/25/09 02:16 PM
Joined: Aug 2009
Posts: 57
R
buff
Offline
buff
R
Joined: Aug 2009
Posts: 57
Fanon,
I would say the back is the way to go. I just replaced the amp in my EP500. It is very quick and easy to get into the sub from the back. There are 12 allen head screws to take out. First remove the power cord and all other imputs. Take out the 12 screws and if amp appears stuck gently grab onto the bananna plug imput terminals and lift up. Amp will come out. You will see that the back of the amp is enclosed by plastic, but you will find a black and a red screw terminal. Make sure the wires are tight on these terminals as well as terminals on the back side of the driver which you will be able to easily see.

Good luck,
Rvrrat

Re: My EP500 just died and I am in need of some ad
rvrrat #283785 12/25/09 02:48 PM
Joined: Apr 2007
Posts: 4,872
connoisseur
Offline
connoisseur
Joined: Apr 2007
Posts: 4,872
I have removed both the amp and the woofer from my ep500 and find that they both come off very easy, but the amp goes back on a little easier. For some reason having the heavy magnet on the back of the woofer makes it a little tricky to align with the holes. Make sure you leave the top screws for last when removing the amp, it makes it a little easier.

Make sure that you don't over tighten the screws when you put it back on though.


-David
Re: My EP500 just died and I am in need of some ad
terzaghi #283797 12/25/09 05:08 PM
Joined: May 2003
Posts: 18,044
shareholder in the making
Offline
shareholder in the making
Joined: May 2003
Posts: 18,044
Did you try the high level inputs, too?

Like David said, the woofers are tricky to put in. I haven't attempted an amp yet--that'll be next week.


I am the Doctor, and THIS... is my SPOON!
Re: My EP500 just died and I am in need of some ad
Ken.C #283807 12/25/09 05:40 PM
Joined: Dec 2008
Posts: 6,928
axiomite
Offline
axiomite
Joined: Dec 2008
Posts: 6,928
I would think the best way to install the woofer would be to lay the cabinet on it's back carefully, (to not damage any amp controls), taking the weight off the screws for mounting. Maybe easier in theory though, 'cause you need to have room to turn the sub over.


Half of communication is listening. You can't listen with your mouth.
Re: My EP500 just died and I am in need of some ad
Adrian #283818 12/25/09 07:08 PM
Joined: Jan 2004
Posts: 13,682
Likes: 1
shareholder in the making
Offline
shareholder in the making
Joined: Jan 2004
Posts: 13,682
Likes: 1
The front driver is very easy to remove, it is heavy so be careful when you take out the last screw. From there you should be able to carefully set it down and look inside to see if any of the wires have come loose.


M80s VP180 4xM22ow 4xM3ic EP600 2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800


Page 1 of 3 1 2 3

Moderated by  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 

Link Copied to Clipboard

Need Help Graphic

Forum Statistics
Forums16
Topics24,365
Posts431,736
Members15,414
Most Online2,082
Jan 22nd, 2020
Top Posters
Ken.C 18,044
pmbuko 16,437
SirQuack 13,682
CV 11,798
MarkSJohnson 11,450
Who's Online Now
2 members (onn, Mojo), 172 guests, and 4 robots.
Key: Admin, Global Mod, Mod
Newsletter Signup
Powered by UBB.threads™ PHP Forum Software 7.7.4