You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » My EP500 just died and I am in need of some advice

Page 1 of 3 1 2 3 >
Topic Options
Rate This Topic
#283777 - 12/25/09 08:33 AM My EP500 just died and I am in need of some advice
fanon Offline
frequent flier

Registered: 07/27/08
Posts: 10
Loc: Belgium - Brussels
Hi There,

My EP500 just died under my hands after working without any problems whatsover since august 2008.
Here's what happened. I just swithed it off, disconnected the AV cord and shielded cable from my AV. Gentle turned the EP500 on it's side, and replaced the spikes with the rubber feet. I then connected all leads again and swithed it on. Big Silence... :-(
The green light is on and I can hear a very soft humming from the ac transformer I think. I have checked all the fuses - 6 in total - but no success, there all okay. If I switch the AC on and then off, I hear a very soft boem... but the EP500 simple refuses to output any sound (I made sure, it's not my AV, I ve got an old SW)
Before going into the hassle of shipping it back (I live in Belgium) I would like to know if there's anything else left which I could do myself. I was thinking in terms of opening the box and checking the wiring. What's the best way of opening the box - at the front (the driver) or at the back? In case of the letter which screws do I have to loosen. I do have a background in electronics. Would checking this myself void my warrantee?
I would be very grateful for advice as I am a bit stuck.
Thanks.

Top
#283779 - 12/25/09 08:40 AM Re: My EP500 just died and I am in need of some advice [Re: fanon]
EFalardeau Offline
connoisseur

Registered: 08/27/07
Posts: 3400
Loc: Laval, Quebec, Canada
Most Axiom products (including the subwoofers) are built to allow the customers to execute repaires and installs to avoid shipping the whole boxes. It really sounds like a wire got loose in the shuffling.
Since this is the 25th, I don't know if they have someone working at customer service, but it is worth a try. They will tell you immediately about the warranty.
_________________________
E = MC2 = ((2M80 + VP180 + 4QS8)/(EP800 + EP500))^(ADA1500 x D2v)
AxiomAir/6xM2/4xM22/2xVP150/2xM3

Top
#283781 - 12/25/09 08:48 AM Re: My EP500 just died and I am in need of some advice [Re: EFalardeau]
Wid Offline
axiomite

Registered: 06/22/03
Posts: 6790
Loc: The Peoples Republic of Il.

I agree, sounds like a wire has come loose.
_________________________
Rick


"A fear of weapons is a sign of retarded sexual and emotional maturity." Sigmund Freud


Top
#283782 - 12/25/09 08:59 AM Re: My EP500 just died and I am in need of some advice [Re: Wid]
MarkSJohnson Offline
shareholder in the making

Registered: 09/27/04
Posts: 11445
Loc: Central NH
I would try hooking up a disc player or MP3 player to it's inputs just to make sure....

I know you didn't post about making changes to anything else but the sub, but I'd check anyway since it only takes a moment.
_________________________
::::::: No disrespect to Axiom, but my favorite woofer is my yellow lab :::::::

Top
#283783 - 12/25/09 09:14 AM Re: My EP500 just died and I am in need of some advice [Re: MarkSJohnson]
fanon Offline
frequent flier

Registered: 07/27/08
Posts: 10
Loc: Belgium - Brussels
Mark, I 've done so but it stays dead .... ths anyway

Apart from my warranty question - anybody has the wisdom on which side to open the EP500 box (for best check up) and with which screws ?

Top
#283784 - 12/25/09 09:16 AM Re: My EP500 just died and I am in need of some advice [Re: MarkSJohnson]
rvrrat Offline
buff

Registered: 08/22/09
Posts: 57
Loc: Iowa, USA
Fanon,
I would say the back is the way to go. I just replaced the amp in my EP500. It is very quick and easy to get into the sub from the back. There are 12 allen head screws to take out. First remove the power cord and all other imputs. Take out the 12 screws and if amp appears stuck gently grab onto the bananna plug imput terminals and lift up. Amp will come out. You will see that the back of the amp is enclosed by plastic, but you will find a black and a red screw terminal. Make sure the wires are tight on these terminals as well as terminals on the back side of the driver which you will be able to easily see.

Good luck,
Rvrrat

Top
#283785 - 12/25/09 09:48 AM Re: My EP500 just died and I am in need of some ad [Re: rvrrat]
terzaghi Offline
connoisseur

Registered: 04/04/07
Posts: 4872
Loc: Tulsa, Oklahoma
I have removed both the amp and the woofer from my ep500 and find that they both come off very easy, but the amp goes back on a little easier. For some reason having the heavy magnet on the back of the woofer makes it a little tricky to align with the holes. Make sure you leave the top screws for last when removing the amp, it makes it a little easier.

Make sure that you don't over tighten the screws when you put it back on though.
_________________________
-David

Top
#283797 - 12/25/09 12:08 PM Re: My EP500 just died and I am in need of some ad [Re: terzaghi]
Ken.C Offline
shareholder in the making

Registered: 05/03/03
Posts: 18044
Loc: NoVA
Did you try the high level inputs, too?

Like David said, the woofers are tricky to put in. I haven't attempted an amp yet--that'll be next week.
_________________________
I am the Doctor, and THIS... is my SPOON!

Top
#283807 - 12/25/09 12:40 PM Re: My EP500 just died and I am in need of some ad [Re: Ken.C]
Adrian Offline
axiomite

Registered: 12/27/08
Posts: 6913
Loc: It's all about the location.
I would think the best way to install the woofer would be to lay the cabinet on it's back carefully, (to not damage any amp controls), taking the weight off the screws for mounting. Maybe easier in theory though, 'cause you need to have room to turn the sub over.
_________________________
Half of communication is listening. You can't listen with your mouth.

Top
#283818 - 12/25/09 02:08 PM Re: My EP500 just died and I am in need of some ad [Re: Adrian]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13611
Loc: Iowa
The front driver is very easy to remove, it is heavy so be careful when you take out the last screw. From there you should be able to carefully set it down and look inside to see if any of the wires have come loose.
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
AnthemAVM60 Outlaw7700 EmoA500 Epson5040UB SonyUBPX800



Top
Page 1 of 3 1 2 3 >

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,334 Registered Members
16 Forums
24,193 Topics
427,704 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13611
CV 11734
MarkSJohnson 11445
0 registered ()
275 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup