You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » EP350 subwoofer connection issue

Topic Options
Rate This Topic
#421852 - 12/31/16 05:17 PM EP350 subwoofer connection issue
chuck122 Offline
newbie

Registered: 12/31/16
Posts: 2
My wife moved my prize subwoofer and snapped off the line in female subwoofer connecter input . Other than shipping the 350 back for service how can I connect my subwoofer cable to the 350? The output from my pioneer elite is via a subwoofer cable.
thanks!

Top
#421853 - 12/31/16 05:42 PM Re: EP350 subwoofer connection issue [Re: chuck122]
Jc Offline

aficionado

Registered: 06/27/06
Posts: 525
Loc: Sherbrooke, QC, Canada
Hi,

On your subwoofer, use the output connector instead of the input one. If there is no internal damage, it will work perfectly and performance wise it will be identical as if you were using the input one.
_________________________
jc

Top
#421856 - 12/31/16 07:06 PM Re: EP350 subwoofer connection issue [Re: chuck122]
SirQuack Offline
shareholder in the making

Registered: 01/29/04
Posts: 13571
Loc: Iowa
Yep as JC mentioned. Some people use these jacks to "daisy chain" multiple subs together. If the other one is not damaged you should be fine.
_________________________
M80s-VP180-4xM22ow-4xM3ic-EP600-2xEP350
Anthem AVM60 Outlaw 7700 Emotiva A500 Epson 5040UB



Top
#421865 - 01/01/17 12:52 AM Re: EP350 subwoofer connection issue [Re: chuck122]
Mojo Offline
connoisseur

Registered: 01/21/07
Posts: 4698
Jc's and Randy's advice is pure hogwash!

Tell your wife she busted your sub and you need a new one (EP800). smile

Top
#421883 - 01/01/17 02:36 PM Re: EP350 subwoofer connection issue [Re: Mojo]
Jc Offline

aficionado

Registered: 06/27/06
Posts: 525
Loc: Sherbrooke, QC, Canada
True, I stand corrected . . .

The perfect solution !

Happy New Year !


Edited by Jc (01/01/17 02:36 PM)
_________________________
jc

Top
#421902 - 01/01/17 06:16 PM Re: EP350 subwoofer connection issue [Re: chuck122]
chuck122 Offline
newbie

Registered: 12/31/16
Posts: 2
Thanks so much. I bought a new cable with male to male terminals and it works like she never even broke it. Since I can't justify a new sub I'll need to make my wife provide my restitution in other ways. Happy New Year.

Top

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,233 Registered Members
15 Forums
24,008 Topics
424,190 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13571
CV 11677
MarkSJohnson 11437
0 registered ()
202 Guests and
3 Spiders online.
Key: Admin, Global Mod, Mod
Newsletter Signup