You are not logged in. [Log In]


Forums » General Discussion » Technical Questions » New ADA 1500 problem

Page 3 of 3 < 1 2 3
Topic Options
Rate This Topic
#399204 - 12/12/13 09:47 AM Re: New ADA 1500 problem [Re: radtek2]
casey01 Offline
aficionado

Registered: 07/03/08
Posts: 852
Loc: Toronto
I have been in a couple of the large distribution centers for both FedEx and UPS and if you saw the way some of these tens of thousands of parcels and boxes are handled you would cringe and at the same time, wonder how more goods aren't damaged. We are usually talking overnight loading and unloading and I think some of these guys doing the work are half asleep. There also could be two or three loading and unloading cycles before it even gets on the truck to be delivered to the buyer's home and that further increases the chance for damage.

The trouble is there is unfortunately, only a handful of companies that can do this kind of high volume international shipping so we are stuck with them and hope for the best when our shipment arrives.

Top
#399205 - 12/12/13 11:30 AM Re: New ADA 1500 problem [Re: casey01]
radtek2 Offline
old hand

Registered: 08/05/04
Posts: 78
Loc: Yelm, WA
I know it's a crap shoot with these companies. I have bought 2 sets of M80s systems(2004 and 2010) and they arrived in great shape. Not to give an excuse but maybe a reason but they were much larger heavier boxes (harder to throw maybe) and a different time of year. The holidays must increase their volume 10 fold!

When tracking the delivery I see the driver loaded his truck for delivery to my house 20 miles away at 2:51 AM and it arrived that evening at 7 PM....long day indeed.

Since I am and old retired goat I am going to spend the rest of the day getting familiar with the 1500 and have some listening fun.
grin
_________________________
M80s VP180 QS8 SVS PC13 Ultra & 20-39PCi
NAD T785HD Oppo95
AntiMode8033
ADA 1500 Amp
Pio 151

Top
#399212 - 12/13/13 02:10 PM Re: New ADA 1500 problem [Re: radtek2]
JBG Offline
devotee

Registered: 06/14/02
Posts: 485
I just wonder.. got my 100's delivered the other day to my home, nobody was there so the ups driver just left them in plain view in front of my garage!!! you could see on the box > high performace loadspeaker.. happy they were still there when I got home!!
_________________________
7.1.4 * MRX1120 * M100s * 180HP * 4x M3-on walls * 4x M3-IC * dual XV15se * Shakers

Top
#399218 - 12/13/13 05:12 PM Re: New ADA 1500 problem [Re: JBG]
onn Offline
aficionado

Registered: 02/28/08
Posts: 999
Loc: Edmonton Alberta
That's how I discovered my LFR's. Sitting on my front porch. mad


Edited by onn (12/13/13 05:13 PM)
_________________________
My system

Top
Page 3 of 3 < 1 2 3

Moderator:  alan, Amie, Andrew, axiomadmin, Brent, Debbie, Ian, Jc 
Forum Stats

15,238 Registered Members
15 Forums
24,017 Topics
424,283 Posts

Most users ever online:
883 @ 03/04/17 05:06 PM

Top Posters
Ken.C 18044
pmbuko 16437
SirQuack 13571
CV 11677
MarkSJohnson 11437
1 registered (aarons)
209 Guests and
1 Spider online.
Key: Admin, Global Mod, Mod
Newsletter Signup